summaryrefslogtreecommitdiffstats
path: root/system/sandy
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2021-08-23 16:27:38 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2021-10-13 00:51:36 +0700
commitc2e2304deba1be1b2904c36fc940490223688abd (patch)
tree8de5d981635bc3107084d23dcbd804328d7610f8 /system/sandy
parentc6a1678ff3d5ccda5e18e29c02e8cf79c96133d8 (diff)
downloadslackbuilds-c2e2304deba1be1b2904c36fc940490223688abd.tar.gz
slackbuilds-c2e2304deba1be1b2904c36fc940490223688abd.tar.xz
system/sandy: Remove template comment.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'system/sandy')
-rw-r--r--system/sandy/README10
-rw-r--r--system/sandy/sandy.SlackBuild10
2 files changed, 7 insertions, 13 deletions
diff --git a/system/sandy/README b/system/sandy/README
index 8146b5e8ed..f74a2a4bd3 100644
--- a/system/sandy/README
+++ b/system/sandy/README
@@ -15,14 +15,14 @@ Features / Non-features
- Very simple commands read from a named pipe
- Very basic, regex-based syntax colouring
- Xterm-like mouse support
-- X11 integration is achieved through external tools such as xsel and dmenu
+- X11 integration via external tools such as xsel and dmenu
- Lacks many text processing facilities that can be easily achieved by
piping text through an external command
-If you want to customize the compile-time config, place your config.h in
-the same directory as the SlackBuild script. To get the default config.h,
-extract it from the source tarball (it's called config.def.h there,
-just rename it).
+If you want to customize the compile-time config, place your config.h
+in the same directory as the SlackBuild script. To get the default
+config.h, extract it from the source tarball (it's called config.def.h
+there, just rename it).
Optional dependencies: If xsel and/or dmenu are installed, sandy uses
them at runtime for X11 integration.
diff --git a/system/sandy/sandy.SlackBuild b/system/sandy/sandy.SlackBuild
index eca60921bb..d3dd550e27 100644
--- a/system/sandy/sandy.SlackBuild
+++ b/system/sandy/sandy.SlackBuild
@@ -32,9 +32,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -67,11 +64,8 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# just in case...
sed -i "s,\<lib\>,lib$LIBDIRSUFFIX,g" config.mk