summaryrefslogtreecommitdiffstats
path: root/academic/bowtie/patches/no_hash_style_both_for_mips.patch
diff options
context:
space:
mode:
Diffstat (limited to 'academic/bowtie/patches/no_hash_style_both_for_mips.patch')
-rw-r--r--academic/bowtie/patches/no_hash_style_both_for_mips.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/academic/bowtie/patches/no_hash_style_both_for_mips.patch b/academic/bowtie/patches/no_hash_style_both_for_mips.patch
new file mode 100644
index 0000000000..c7f8ab32e1
--- /dev/null
+++ b/academic/bowtie/patches/no_hash_style_both_for_mips.patch
@@ -0,0 +1,20 @@
+Description: Disable -Wl,--hash-style=both on mips machines.
+ It's not supported on mips and mipsel ports and leads to build errors.
+Author: Ognyan Kulev <ogi@debian.org>
+Forwarded: not-needed
+Last-Update: 2013-04-24
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- bowtie-1.0.0.orig/Makefile
++++ bowtie-1.0.0/Makefile
+@@ -45,7 +45,9 @@
+ LINUX = 0
+ ifneq (,$(findstring Linux,$(shell uname)))
+ LINUX = 1
+- EXTRA_FLAGS += -Wl,--hash-style=both
++ ifeq (,$(findstring mips,$(shell uname -m)))
++ EXTRA_FLAGS += -Wl,--hash-style=both
++ endif
+ endif
+
+ MM_DEF =