summaryrefslogtreecommitdiffstats
path: root/academic/gmsh/gmsh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'academic/gmsh/gmsh.SlackBuild')
-rw-r--r--academic/gmsh/gmsh.SlackBuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/academic/gmsh/gmsh.SlackBuild b/academic/gmsh/gmsh.SlackBuild
index 9d959c11a6..e318452d91 100644
--- a/academic/gmsh/gmsh.SlackBuild
+++ b/academic/gmsh/gmsh.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for gmsh
-# Copyright 2020-2022 Fellype do Nascimento, Guaratingueta, Brazil
+# Copyright 2020-2024 Fellype do Nascimento, Guaratingueta, Brazil
#
# Based on SlackBuild by Loris Vincenzi and PKGBUILD for gmsh at AUR
#
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gmsh
-VERSION=${VERSION:-4.10.0}
+VERSION=${VERSION:-4.12.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -84,7 +84,9 @@ find -L . \
# do it using BUILDSTATICLIB=yes ./gmsh.SlackBuild
# default is BUILDSTATICLIB=no
if [ "${BUILDSTATICLIB:-no}" = "yes" ]; then
- echo "**building a static library for gmsh**"
+ echo " "
+ echo "** building a static library for gmsh **"
+ echo " "
mkdir lib
cd lib
cmake -DDEFAULT=0 \
@@ -94,12 +96,17 @@ if [ "${BUILDSTATICLIB:-no}" = "yes" ]; then
-DENABLE_BLAS_LAPACK=1 \
-DENABLE_BUILD_LIB=1 \
-DENABLE_PRIVATE_API=1 \
+ -DENABLE_MED=OFF \
+ -DENABLE_CGNS=OFF \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_INSTALL_DOCDIR:PATH=/usr/share/gmsh \
..
make lib
make install/fast DESTDIR=$PKG/
cd ..
+ echo " "
+ echo "** finished building the static library **"
+ echo " "
fi
mkdir build
@@ -113,8 +120,12 @@ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DENABLE_PRIVATE_API=1 \
-DENABLE_PETSC=OFF \
-DENABLE_SLEPC=OFF \
+ -DENABLE_MED=OFF \
+ -DENABLE_CGNS=OFF \
..
# only demos/ and tutorial/ folders will be left in the /usr/share/gmsh dir
+# TODO: Solve runtime issues with HDF5 - this is the reason for disabling
+# MED and CGNS in gmsh 4.12.x
make
make install DESTDIR=$PKG