summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
Diffstat (limited to 'academic')
-rw-r--r--academic/labplot2/README8
-rw-r--r--academic/labplot2/labplot2.SlackBuild20
-rw-r--r--academic/labplot2/labplot2.info8
3 files changed, 30 insertions, 6 deletions
diff --git a/academic/labplot2/README b/academic/labplot2/README
index 184b9e3463..d34496e452 100644
--- a/academic/labplot2/README
+++ b/academic/labplot2/README
@@ -13,4 +13,10 @@ a lot of features available in the predecessor. On the other hand, the
GUI and the usability is more superior as compared to LabPlot1 and there
are several new features that were not available in LabPlot1.
-gsl is an optional dependency.
+optional dependencies:
+
+- LaTeX (to enable LaTeX typesetting in LabPlot)
+- fftw
+- hdf5
+- netcdf
+- cfitsio
diff --git a/academic/labplot2/labplot2.SlackBuild b/academic/labplot2/labplot2.SlackBuild
index ca405b232e..f10f2442bc 100644
--- a/academic/labplot2/labplot2.SlackBuild
+++ b/academic/labplot2/labplot2.SlackBuild
@@ -1,11 +1,29 @@
#!/bin/sh
+#
# Slackware build script for LabPlot
# Based on the Slackware 14.1 SlackBuild and AUR PKGBUILD for labplot
# Written by Fellype do Nascimento <fellype(at)gmail.com>
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
NAME=labplot
PRGNAM=labplot2
-VERSION=${VERSION:-2.3.0}
+VERSION=${VERSION:-2.4.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/academic/labplot2/labplot2.info b/academic/labplot2/labplot2.info
index bc6843ed4e..b9af5858f7 100644
--- a/academic/labplot2/labplot2.info
+++ b/academic/labplot2/labplot2.info
@@ -1,8 +1,8 @@
PRGNAM="labplot2"
-VERSION="2.3.0"
-HOMEPAGE="http://labplot.sourceforge.net/"
-DOWNLOAD="http://kde.c3sl.ufpr.br/stable/labplot/2.3.0/labplot-2.3.0.tar.xz"
-MD5SUM="c1d61b5398cb4eb1ce9f4ba285400ecd"
+VERSION="2.4.0"
+HOMEPAGE="https://labplot.kde.org/"
+DOWNLOAD="http://kde.c3sl.ufpr.br/stable/labplot/2.4.0/labplot-2.4.0.tar.xz"
+MD5SUM="ee59c0095190bb3dc100e29e1a00c654"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="extra-cmake-modules"