summaryrefslogtreecommitdiffstats
path: root/audio/aseqview
diff options
context:
space:
mode:
Diffstat (limited to 'audio/aseqview')
-rw-r--r--audio/aseqview/aseqview.SlackBuild26
-rw-r--r--audio/aseqview/aseqview.info4
-rw-r--r--audio/aseqview/b31044a.patch25
-rw-r--r--audio/aseqview/e40717b.patch42
4 files changed, 90 insertions, 7 deletions
diff --git a/audio/aseqview/aseqview.SlackBuild b/audio/aseqview/aseqview.SlackBuild
index 70c9b6d0b9..47c8e0e142 100644
--- a/audio/aseqview/aseqview.SlackBuild
+++ b/audio/aseqview/aseqview.SlackBuild
@@ -1,15 +1,21 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for aseqview
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210805 bkw, BUILD=2:
+# - build with gtk2 rather than gtk1, apply a couple of upstream fixes.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=aseqview
VERSION=${VERSION:-0.2.8}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,7 +25,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -50,6 +60,11 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+# From upstream's github: fix a segfault and a possible autotools issue.
+# Commits b31044a and e40717b.
+patch -p1 < $CWD/b31044a.patch
+patch -p1 < $CWD/e40717b.patch
+
# 20180916 bkw: need this due to these:
# levelbar.o: In function `g_bit_nth_lsf':
# levelbar.c:(.text+0x410): multiple definition of `g_bit_nth_lsf'
@@ -65,6 +80,7 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-gtk2 \
--build=$ARCH-slackware-linux
make
@@ -88,4 +104,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/aseqview/aseqview.info b/audio/aseqview/aseqview.info
index fb4caff0e2..a9a05df1c8 100644
--- a/audio/aseqview/aseqview.info
+++ b/audio/aseqview/aseqview.info
@@ -1,10 +1,10 @@
PRGNAM="aseqview"
VERSION="0.2.8"
HOMEPAGE="https://github.com/tiwai/aseqview"
-DOWNLOAD="http://ftp.osuosl.org/pub/gentoo/distfiles/aseqview-0.2.8.tar.gz"
+DOWNLOAD="http://ftp.osuosl.org/pub/gentoo/distfiles/7c/aseqview-0.2.8.tar.gz"
MD5SUM="5f75e1b6fc5eab6b40ae2c7a74216a7b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"
diff --git a/audio/aseqview/b31044a.patch b/audio/aseqview/b31044a.patch
new file mode 100644
index 0000000000..20efb01a9e
--- /dev/null
+++ b/audio/aseqview/b31044a.patch
@@ -0,0 +1,25 @@
+From b31044aeddd0b406ddbc262f20a4f069baf26783 Mon Sep 17 00:00:00 2001
+From: Takashi Iwai <tiwai@suse.de>
+Date: Fri, 25 Jun 2021 10:19:39 +0200
+Subject: [PATCH] Fix quote in configure.in
+
+---
+ configure.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index e125908..4b6907f 100644
+--- a/configure.in
++++ b/configure.in
+@@ -12,9 +12,9 @@ AC_C_INLINE
+
+ AH_TEMPLATE([HAVE_LIBCAP], [Hey, we have libcap])
+ AC_CHECK_HEADER(sys/capability.h,
+- AC_CHECK_LIB(cap, cap_get_proc,
++ [AC_CHECK_LIB(cap, cap_get_proc,
+ [AC_DEFINE(HAVE_LIBCAP)
+- LIBS="$LIBS -lcap"]))
++ LIBS="$LIBS -lcap"])])
+
+ AM_PATH_ALSA(0.5.0)
+ AC_CHECK_HEADERS(alsa/asoundlib.h)
diff --git a/audio/aseqview/e40717b.patch b/audio/aseqview/e40717b.patch
new file mode 100644
index 0000000000..2acbd3bec9
--- /dev/null
+++ b/audio/aseqview/e40717b.patch
@@ -0,0 +1,42 @@
+From e40717bcf0d1851465a5d2531b92f6b1da2ce0c0 Mon Sep 17 00:00:00 2001
+From: Takashi Iwai <tiwai@suse.de>
+Date: Fri, 25 Jun 2021 10:20:18 +0200
+Subject: [PATCH] Fix crash at piano widget creation
+
+It was a failure in piano widget that assumed that the widget type is
+an integer. It caused a segfault with the recent gtk.
+---
+ piano.c | 4 ++--
+ piano.h | 2 +-
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/piano.c b/piano.c
+index 7626373..931e3b9 100644
+--- a/piano.c
++++ b/piano.c
+@@ -69,10 +69,10 @@ static GdkColor c60clr = { red : 18000, green : 0, blue : 54000 };
+
+ static GtkWidgetClass *parent_class = NULL;
+
+-guint
++GType
+ piano_get_type (void)
+ {
+- static guint piano_type = 0;
++ static GType piano_type = 0;
+
+ if (!piano_type)
+ {
+diff --git a/piano.h b/piano.h
+index 6dea3b6..c35d7da 100644
+--- a/piano.h
++++ b/piano.h
+@@ -71,7 +71,7 @@ struct _PianoClass
+ };
+
+ GtkWidget *piano_new (gboolean * selkeys);
+-guint piano_get_type (void);
++GType piano_get_type (void);
+ void piano_note_on (Piano * piano, guint8 keynum);
+ void piano_note_off (Piano * piano, guint8 keynum);
+