summaryrefslogtreecommitdiffstats
path: root/audio/grip2/patches
diff options
context:
space:
mode:
Diffstat (limited to 'audio/grip2/patches')
-rw-r--r--audio/grip2/patches/grip2-nptl.diff12
-rw-r--r--audio/grip2/patches/grip2.diff18
-rw-r--r--audio/grip2/patches/system_cdparanoia_libs.diff44
3 files changed, 0 insertions, 74 deletions
diff --git a/audio/grip2/patches/grip2-nptl.diff b/audio/grip2/patches/grip2-nptl.diff
deleted file mode 100644
index 36968fc3fd..0000000000
--- a/audio/grip2/patches/grip2-nptl.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur grip-2.93.orig/grip.c grip-2.93/grip.c
---- grip-2.93.orig/grip.c 2007-04-19 01:15:23.000000000 -0400
-+++ grip-2.93/grip.c 2007-04-19 01:34:39.000000000 -0400
-@@ -1637,7 +1637,7 @@
- #if defined(SOLARIS) || defined(__FreeBSD__)
- pthread_exit(&status);
- #else
-- pthread_kill_other_threads_np();
-+ /* pthread_kill_other_threads_np(); */
- #endif
- Debug("Aborted\n");
- looking_up=FALSE;
diff --git a/audio/grip2/patches/grip2.diff b/audio/grip2/patches/grip2.diff
deleted file mode 100644
index e62fdd2777..0000000000
--- a/audio/grip2/patches/grip2.diff
+++ /dev/null
@@ -1,18 +0,0 @@
-diff -Naur grip-2.96/Makefile grip-2.96.patched//Makefile
---- grip-2.96/Makefile 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96.patched//Makefile 2011-06-27 08:42:13.000000000 -0400
-@@ -72,11 +72,11 @@
-
- install:
- $(INSTALL) -d $(INSTALLDIR)
-- $(INSTALL) grip $(INSTALLDIR)
-- $(INSTALL) gcd $(INSTALLDIR)
-+ $(INSTALL) grip $(INSTALLDIR)/grip$(EXE_SUFFIX)
-+ $(INSTALL) gcd $(INSTALLDIR)/gcd$(EXE_SUFFIX)
- $(INSTALL) -d $(AUXDIR)
- $(INSTALL) -d $(PREFIX)/man/man1
-- $(INSTALL) grip.1 $(PREFIX)/man/man1
-+ $(INSTALL) grip.1 $(PREFIX)/man/man1/grip$(EXE_SUFFIX).1
- $(INSTALL) grip.1 $(PREFIX)/man/man1/gcd.1
-
- gcdinstall:
diff --git a/audio/grip2/patches/system_cdparanoia_libs.diff b/audio/grip2/patches/system_cdparanoia_libs.diff
deleted file mode 100644
index 7656af8107..0000000000
--- a/audio/grip2/patches/system_cdparanoia_libs.diff
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur grip-2.96.orig/Makefile grip-2.96/Makefile
---- grip-2.96.orig/Makefile 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/Makefile 2009-02-05 00:38:28.000000000 -0500
-@@ -28,8 +28,8 @@
- ifeq ($(OS), FreeBSD)
- LIBS+= -pthread
- endif
--PARLIBS= cdparanoia/interface/libcdda_interface.a \
-- cdparanoia/paranoia/libcdda_paranoia.a
-+PARLIBS= -lcdda_interface \
-+ -lcdda_paranoia
-
- # This is needed for "make install"
- OWNER = root
-diff -Naur grip-2.96.orig/cdpar.c grip-2.96/cdpar.c
---- grip-2.96.orig/cdpar.c 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/cdpar.c 2009-02-05 00:39:02.000000000 -0500
-@@ -36,9 +36,9 @@
- #define size16 short
- #define size32 int
-
--#include "cdparanoia/interface/cdda_interface.h"
--#include "cdparanoia/paranoia/cdda_paranoia.h"
--#include "cdparanoia/utils.h"
-+#include <cdda_interface.h>
-+#include <cdda_paranoia.h>
-+#include <utils.h>
-
- static void PutNum(long num,int f,int endianness,int bytes);
- static void WriteWav(int f,long bytes);
-diff -Naur grip-2.96.orig/grip.c grip-2.96/grip.c
---- grip-2.96.orig/grip.c 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/grip.c 2009-02-05 00:42:26.000000000 -0500
-@@ -57,8 +57,8 @@
- #ifdef CDPAR
- #define size16 short
- #define size32 int
--#include "cdparanoia/interface/cdda_interface.h"
--#include "cdparanoia/paranoia/cdda_paranoia.h"
-+#include <cdda_interface.h>
-+#include <cdda_paranoia.h>
- #endif
-
- void ShutDownCB(void);