summaryrefslogtreecommitdiffstats
path: root/audio/pithos
diff options
context:
space:
mode:
Diffstat (limited to 'audio/pithos')
-rw-r--r--audio/pithos/doinst.sh6
-rw-r--r--audio/pithos/pithos.SlackBuild47
-rw-r--r--audio/pithos/pithos.info10
-rw-r--r--audio/pithos/slack-desc2
4 files changed, 45 insertions, 20 deletions
diff --git a/audio/pithos/doinst.sh b/audio/pithos/doinst.sh
index 4a25de5e6f..e924bab47c 100644
--- a/audio/pithos/doinst.sh
+++ b/audio/pithos/doinst.sh
@@ -8,3 +8,9 @@ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
fi
fi
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
+
diff --git a/audio/pithos/pithos.SlackBuild b/audio/pithos/pithos.SlackBuild
index 32579cffe5..63b8f80ddb 100644
--- a/audio/pithos/pithos.SlackBuild
+++ b/audio/pithos/pithos.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for pithos
-# Copyright 2013 Robby Workman, Northport, Alabama, USA
+# Copyright 2013,2017 Robby Workman, Tuscaloosa, Alabama, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,26 +22,36 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=pithos
-VERSION=${VERSION:-git_ed501485}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.5.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,15 +71,24 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
+chown -R root:root $PRGNAM-$VERSION
+find -L $PRGNAM-$VERSION \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+mkdir -p $PRGNAM-$VERSION/build
+meson \
+ --prefix=/usr \
+ --libdir=/usr/lib64 \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ $PRGNAM-$VERSION \
+ $PRGNAM-$VERSION/build
+DESTDIR=$PKG ${NINJA:=ninja} -C $PRGNAM-$VERSION/build install
cat $CWD/contrib/pithosctl > $PKG/usr/bin/pithosctl
chmod 0755 $PKG/usr/bin/pithosctl
@@ -78,7 +97,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $PRGNAM-$VERSION/README.md $PRGNAM-$VERSION/license $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -86,4 +105,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/pithos/pithos.info b/audio/pithos/pithos.info
index c276852bd2..280a6e80ed 100644
--- a/audio/pithos/pithos.info
+++ b/audio/pithos/pithos.info
@@ -1,10 +1,10 @@
PRGNAM="pithos"
-VERSION="git_ed501485"
-HOMEPAGE="http://kevinmehall.net/p/pithos/"
-DOWNLOAD="http://harrier.slackbuilds.org/misc/pithos-git_ed501485.tar.xz"
-MD5SUM="fb7f45ff93b5aab7b60e5b943d7bb024"
+VERSION="1.5.1"
+HOMEPAGE="https://github.com/pithos/pithos"
+DOWNLOAD="https://github.com/pithos/pithos/releases/download/1.5.1/pithos-1.5.1.tar.xz"
+MD5SUM="bdc76b76fc20e17fddb2021884f919d6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gst0-python gst0-ffmpeg"
+REQUIRES="gst-python"
MAINTAINER="Robby Workman"
EMAIL="rworkman@slackbuilds.org"
diff --git a/audio/pithos/slack-desc b/audio/pithos/slack-desc
index 3ac97f0f7d..c55001e893 100644
--- a/audio/pithos/slack-desc
+++ b/audio/pithos/slack-desc
@@ -13,7 +13,7 @@ pithos: lightweight than the Pandora.com web client and integrates with
pithos: desktop features such as media keys, notifications, and the sound
pithos: menu.
pithos:
-pithos: Homepage: http://kevinmehall.net/p/pithos/
+pithos: Homepage: https://github.com/pithos/pithos
pithos:
pithos:
pithos: