summaryrefslogtreecommitdiffstats
path: root/audio/tuner
diff options
context:
space:
mode:
Diffstat (limited to 'audio/tuner')
-rw-r--r--audio/tuner/README3
-rw-r--r--audio/tuner/doinst.sh15
-rw-r--r--audio/tuner/slack-desc19
-rw-r--r--audio/tuner/tuner.SlackBuild116
-rw-r--r--audio/tuner/tuner.info10
5 files changed, 163 insertions, 0 deletions
diff --git a/audio/tuner/README b/audio/tuner/README
new file mode 100644
index 0000000000..81fadd6a30
--- /dev/null
+++ b/audio/tuner/README
@@ -0,0 +1,3 @@
+tuner (Minimalist radio station player)
+
+Discover and Listen to your favourite internet radio stations.
diff --git a/audio/tuner/doinst.sh b/audio/tuner/doinst.sh
new file mode 100644
index 0000000000..401d987795
--- /dev/null
+++ b/audio/tuner/doinst.sh
@@ -0,0 +1,15 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
diff --git a/audio/tuner/slack-desc b/audio/tuner/slack-desc
new file mode 100644
index 0000000000..f195048b55
--- /dev/null
+++ b/audio/tuner/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tuner: tuner (Minimalist radio station player)
+tuner:
+tuner: Discover and Listen to your favourite internet radio stations.
+tuner:
+tuner:
+tuner:
+tuner:
+tuner:
+tuner:
+tuner: https://codeberg.org/tuner/tuner
+tuner:
diff --git a/audio/tuner/tuner.SlackBuild b/audio/tuner/tuner.SlackBuild
new file mode 100644
index 0000000000..235bfc1252
--- /dev/null
+++ b/audio/tuner/tuner.SlackBuild
@@ -0,0 +1,116 @@
+#!/bin/bash
+
+# Slackware build script for tuner
+
+# Copyright 2023 Johannes Schoepfer, Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=tuner
+VERSION=${VERSION:-1.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+else
+ SLKCFLAGS="-O2"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# Remove com.github.louis77 from filenames
+GITHUB_NAME=com.github.louis77
+mv $GITHUB_NAME.$PRGNAM.yml $PRGNAM.yml
+for src_nam in meson.build data/$GITHUB_NAME.$PRGNAM.desktop.in; do
+ sed "s/$GITHUB_NAME.//g" -i $src_nam
+done
+for icon_size in 16 24 32 48 64 128; do
+ for icon in tuner.png tuner-symbolic.png tuner.svg; do
+ mv data/icons/$icon_size/$GITHUB_NAME.$icon data/icons/$icon_size/$icon
+ done
+done
+for src_nam in appdata.xml.in desktop.in gresource.xml gschema.xml; do
+ mv data/$GITHUB_NAME.$PRGNAM.$src_nam data/$PRGNAM.$src_nam
+done
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --localstatedir=/var \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE NOTES.md PACKAGING.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/audio/tuner/tuner.info b/audio/tuner/tuner.info
new file mode 100644
index 0000000000..b1a81c33da
--- /dev/null
+++ b/audio/tuner/tuner.info
@@ -0,0 +1,10 @@
+PRGNAM="tuner"
+VERSION="1.5.1"
+HOMEPAGE="https://codeberg.org/tuner/tuner"
+DOWNLOAD="https://github.com/louis77/tuner/archive/1.5.1/tuner-1.5.1.tar.gz"
+MD5SUM="ee07ecb7d309e5c963dd550b593aa1ba"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="granite geoclue2 geocode-glib"
+MAINTAINER="Johannes Schoepfer"
+EMAIL="slackbuilds@schoepfer.info"