summaryrefslogtreecommitdiffstats
path: root/desktop/awn-extras
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/awn-extras')
-rw-r--r--desktop/awn-extras/README3
-rw-r--r--desktop/awn-extras/awn-extras.SlackBuild129
-rw-r--r--desktop/awn-extras/awn-extras.info10
-rw-r--r--desktop/awn-extras/doinst.sh43
-rw-r--r--desktop/awn-extras/glib-single-include.patch226
-rw-r--r--desktop/awn-extras/libnotify-0.7.patch11
-rw-r--r--desktop/awn-extras/slack-desc19
7 files changed, 0 insertions, 441 deletions
diff --git a/desktop/awn-extras/README b/desktop/awn-extras/README
deleted file mode 100644
index 5b162d6542..0000000000
--- a/desktop/awn-extras/README
+++ /dev/null
@@ -1,3 +0,0 @@
-AWN Extras Plugins
-
-Collection of plugins for Avant Window Navigator.
diff --git a/desktop/awn-extras/awn-extras.SlackBuild b/desktop/awn-extras/awn-extras.SlackBuild
deleted file mode 100644
index c4498e82e9..0000000000
--- a/desktop/awn-extras/awn-extras.SlackBuild
+++ /dev/null
@@ -1,129 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for awn-extras
-
-# Copyright (c) 2010 Roberto Metere. All rights reserved.
-# Copyright 2014 Ryan P.C. McQuen, WA, ryanpcmcquen@member.fsf.org
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=awn-extras
-VERSION=${VERSION:-0.4.0}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Starting with glib 2.32 it is now mandatory to
-# include glib.h instead of individual headers.
-patch -p1 -i $CWD/glib-single-include.patch
-
-# Fix for libnotify 0.7
-patch -p0 -i $CWD/libnotify-0.7.patch
-
-# Configure
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --without-gnome \
- --enable-shave \
- --with-webkit \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-static=yes \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-# Some error on 64 bit system which I can't figure out to handle in other way
-if [ "$ARCH" == "x86_64" ]
-then
- MAKEFILES=$(ls -1 */*/*/Makefile */*/Makefile */Makefile Makefile)
- for i in $MAKEFILES
- do
- printf "Fixing \"$i\"... "
- cat $i | sed "s/\/lib\ /\/lib${LIBDIRSUFFIX}\ /g" > $i.new
- mv $i.new $i
- printf "done.\n"
- done
-fi
-
-# Build and install
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-cd $PKG/usr/doc/$PRGNAM-$VERSION
-ln -s ../../share/gtk-doc/html/libawn html
-
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/awn-extras/awn-extras.info b/desktop/awn-extras/awn-extras.info
deleted file mode 100644
index 462128723d..0000000000
--- a/desktop/awn-extras/awn-extras.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="awn-extras"
-VERSION="0.4.0"
-HOMEPAGE="https://launchpad.net/awn-extras"
-DOWNLOAD="https://launchpad.net/awn-extras/0.4/0.4.0/+download/awn-extras-0.4.0.tar.gz"
-MD5SUM="b559d68cd6ad295c961c20fcc5d9f9c0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="avant-window-navigator feedparser gdata gst0-python gnome-python-desktop pyinotify vala vobject webkitgtk"
-MAINTAINER="orphaned - no maintainer"
-EMAIL="nobody@nowhere"
diff --git a/desktop/awn-extras/doinst.sh b/desktop/awn-extras/doinst.sh
deleted file mode 100644
index c9ca198235..0000000000
--- a/desktop/awn-extras/doinst.sh
+++ /dev/null
@@ -1,43 +0,0 @@
-schema_install() {
- SCHEMA="$1"
- GCONF_CONFIG_SOURCE="xml::etc/gconf/gconf.xml.defaults" \
- chroot . gconftool-2 --makefile-install-rule \
- /etc/gconf/schemas/$SCHEMA \
- 1>/dev/null
-}
-
-schema_install awn-applet-calendar.schemas
-schema_install awn-applet-battery.schemas
-schema_install awn-applet-mount.schemas
-schema_install awn-applet-notification-area.schemas
-schema_install awn-applet-places.schemas
-schema_install awn-applet-sysmon.schemas
-schema_install awn-applet-slickswitcher.schemas
-schema_install awn-applet-bandwidth-monitor.schemas
-schema_install awn-applet-to-do.schemas
-schema_install awn-applet-notification-daemon.schemas
-schema_install awn-applet-feeds.schemas
-schema_install awn-applet-mail.schemas
-schema_install awn-applet-media-control.schemas
-schema_install awn-applet-cpufreq.schemas
-schema_install awn-applet-digital-clock.schemas
-schema_install awnsystemmonitor.schemas
-schema_install awn-applet-weather.schemas
-schema_install awn-applet-shinyswitcher.schemas
-schema_install awn-applet-volume-control.schemas
-schema_install awn-applet-webapplet.schemas
-schema_install awn-applet-garbage.schemas
-schema_install awn-applet-cairo-clock.schemas
-schema_install awn-applet-quit.schemas
-schema_install awn-applet-hardware-sensors.schemas
-schema_install awn-applet-file-browser-launcher.schemas
-schema_install awn-applet-media-player.schemas
-schema_install awn-applet-comics.schemas
-schema_install awn-applet-awnterm.schemas
-schema_install awn-applet-dialect.schemas
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/desktop/awn-extras/glib-single-include.patch b/desktop/awn-extras/glib-single-include.patch
deleted file mode 100644
index bb2d339f17..0000000000
--- a/desktop/awn-extras/glib-single-include.patch
+++ /dev/null
@@ -1,226 +0,0 @@
-Index: awn-extras-0.4.0/applets/maintained/awnterm/keybinder.h
-===================================================================
---- awn-extras-0.4.0.orig/applets/maintained/awnterm/keybinder.h
-+++ awn-extras-0.4.0/applets/maintained/awnterm/keybinder.h
-@@ -24,7 +24,7 @@
- #ifndef __AWN_KEY_BINDER_H__
- #define __AWN_KEY_BINDER_H__
-
--#include <glib/gtypes.h>
-+#include <glib.h>
-
- G_BEGIN_DECLS
-
-Index: awn-extras-0.4.0/applets/maintained/notification-daemon/daemon.h
-===================================================================
---- awn-extras-0.4.0.orig/applets/maintained/notification-daemon/daemon.h
-+++ awn-extras-0.4.0/applets/maintained/notification-daemon/daemon.h
-@@ -31,8 +31,6 @@
-
- #include <libawn/awn-applet.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-cairo-utils.h>
-Index: awn-extras-0.4.0/applets/maintained/notification-daemon/engines.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/maintained/notification-daemon/engines.c
-+++ awn-extras-0.4.0/applets/maintained/notification-daemon/engines.c
-@@ -38,8 +38,7 @@
-
-
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
-@@ -50,7 +49,6 @@
-
- #include <string.h>
- #include <gtk/gtk.h>
--#include <glib.h>
- #ifndef HAVE_GTK_URL_LABEL
- #include <libsexy/sexy-url-label.h>
- #endif
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/awnsystemmonitor.h
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/awnsystemmonitor.h
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/awnsystemmonitor.h
-@@ -25,7 +25,7 @@
- //#include <libawn/awn-title.h>
- #include <libawn/awn-tooltip.h>
-
--#include <glib/gtypes.h>
-+#include <glib.h>
- #include <glibtop/cpu.h>
- #include <gconf/gconf-client.h>
-
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/awntop_cairo_component.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/awntop_cairo_component.c
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/awntop_cairo_component.c
-@@ -43,13 +43,11 @@
-
-
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib.h>
- #include <gtk/gtk.h>
-
-
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/cpu_component.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/cpu_component.c
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/cpu_component.c
-@@ -18,13 +18,11 @@
- */
-
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib.h>
- #include <gtk/gtk.h>
- #include <gdk/gdk.h>
- #include <string.h>
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/cpumetergconf.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/cpumetergconf.c
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/cpumetergconf.c
-@@ -20,13 +20,10 @@
- * Boston, MA 02111-1307, USA.
- */
- #include <string.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
- #include <gconf/gconf-value.h>
-
- #include "cairo-utils.h"
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/dashboard.h
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/dashboard.h
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/dashboard.h
-@@ -23,13 +23,11 @@
-
-
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib.h>
- #include <gtk/gtk.h>
-
- #include <glibtop/mem.h>
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/date_time_component.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/date_time_component.c
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/date_time_component.c
-@@ -19,13 +19,11 @@
-
-
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib.h>
- #include <gtk/gtk.h>
- #include <gdk/gdk.h>
- #include <string.h>
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/loadavg_component.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/loadavg_component.c
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/loadavg_component.c
-@@ -19,13 +19,11 @@
-
- #include <glibtop/loadavg.h>
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib.h>
- #include <gtk/gtk.h>
- #include <gdk/gdk.h>
- #include <string.h>
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/sysmem_component.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/sysmem_component.c
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/sysmem_component.c
-@@ -19,13 +19,11 @@
-
- #include <glibtop/mem.h>
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib.h>
- #include <gtk/gtk.h>
- #include <gdk/gdk.h>
- #include <string.h>
-Index: awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/uptime_component.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/awnsystemmonitor/uptime_component.c
-+++ awn-extras-0.4.0/applets/unmaintained/awnsystemmonitor/uptime_component.c
-@@ -1,12 +1,10 @@
-
- #include <libawn/awn-applet.h>
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <gconf/gconf-value.h>
-
- #include <libawn/awn-dialog.h>
- #include <libawn/awn-applet-simple.h>
--#include <glib.h>
-
- #include <glibtop/uptime.h>
- #include <glibtop/cpu.h>
-Index: awn-extras-0.4.0/applets/unmaintained/main-menu/applet.c
-===================================================================
---- awn-extras-0.4.0.orig/applets/unmaintained/main-menu/applet.c
-+++ awn-extras-0.4.0/applets/unmaintained/main-menu/applet.c
-@@ -23,8 +23,7 @@
-
- #include <string.h>
-
--#include <glib/gmacros.h>
--#include <glib/gerror.h>
-+#include <glib.h>
- #include <glib/gi18n.h>
- #include <gtk/gtk.h>
- #include <libdesktop-agnostic/fdo.h>
diff --git a/desktop/awn-extras/libnotify-0.7.patch b/desktop/awn-extras/libnotify-0.7.patch
deleted file mode 100644
index 5171adeea7..0000000000
--- a/desktop/awn-extras/libnotify-0.7.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- applets/maintained/notification-daemon/daemon.c
-+++ applets/maintained/notification-daemon/daemon.c
-@@ -1487,7 +1487,7 @@
- if (fork() == 0)
- {
- notify_init("notify-send");
-- notify = notify_notification_new(summary, body, icon_str, NULL);
-+ notify = notify_notification_new(summary, body, icon_str);
- notify_notification_set_category(notify, type);
- notify_notification_set_urgency(notify, urgency);
- notify_notification_set_timeout(notify, expire_timeout);
diff --git a/desktop/awn-extras/slack-desc b/desktop/awn-extras/slack-desc
deleted file mode 100644
index bc4fa77ed8..0000000000
--- a/desktop/awn-extras/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-awn-extras: awn-extras (plugins for Avant Window Navigator)
-awn-extras:
-awn-extras: AWN extras is a sub-project of Awn, which concentrates on efforts
-awn-extras: around Awn, including applets for Awn.
-awn-extras:
-awn-extras: Homepage: https://launchpad.net/awn-extras
-awn-extras:
-awn-extras:
-awn-extras:
-awn-extras:
-awn-extras: