summaryrefslogtreecommitdiffstats
path: root/desktop/fbpanel/fbpanel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/fbpanel/fbpanel.SlackBuild')
-rw-r--r--desktop/fbpanel/fbpanel.SlackBuild44
1 files changed, 26 insertions, 18 deletions
diff --git a/desktop/fbpanel/fbpanel.SlackBuild b/desktop/fbpanel/fbpanel.SlackBuild
index 4eb8ab914e..ce0fbf5b21 100644
--- a/desktop/fbpanel/fbpanel.SlackBuild
+++ b/desktop/fbpanel/fbpanel.SlackBuild
@@ -12,7 +12,7 @@
# Modified by the SlackBuilds.org project
PRGNAM=fbpanel
-VERSION=4.12
+VERSION=6.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -33,10 +33,16 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -44,7 +50,7 @@ set -e
rm -rf $PKG $TMP/$PRGNAM-$VERSION
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tgz
+tar xvf $CWD/$PRGNAM-$VERSION.tbz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -53,31 +59,33 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+# --cxflags option don't work very well...
+sed -i "s|-O2 -Wall|$SLKCFLAGS -Wall|" rules.mk
+LIBSTOLINK="-lX11 -lgdk_pixbuf-2.0 -lgobject-2.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -lm"
+
./configure \
--prefix=/usr \
- --cpu=on
+ --libdir=/usr/lib$LIBDIRSUFFIX \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --host=$ARCH \
+ --ldflagsx="$LIBSTOLINK" \
+ --build=$ARCH-slackware-linux
make
-make install PREFIX=$PKG/usr
+make DESTDIR=$PKG install
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Strip the fbpanel binary
-strip --strip-unneeded $PKG/usr/bin/fbpanel
+# Forgotten by the "make install"
+mkdir -p $PKG/usr/man/man1
+gzip -c data/man/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- README CHANGELOG COPYING CREDITS INSTALL \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README CHANGELOG COPYING CREDITS NOTES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-# Fix manpage location and compress pages
-mv $PKG/usr/share/man $PKG/usr
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
-
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc