summaryrefslogtreecommitdiffstats
path: root/desktop/gnome-weather
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/gnome-weather')
-rw-r--r--desktop/gnome-weather/4be71525f07189e97720688472172604879d49a5.patch26
-rw-r--r--desktop/gnome-weather/README2
-rw-r--r--desktop/gnome-weather/doinst.sh15
-rw-r--r--desktop/gnome-weather/gnome-weather.SlackBuild114
-rw-r--r--desktop/gnome-weather/gnome-weather.info10
-rw-r--r--desktop/gnome-weather/slack-desc19
6 files changed, 186 insertions, 0 deletions
diff --git a/desktop/gnome-weather/4be71525f07189e97720688472172604879d49a5.patch b/desktop/gnome-weather/4be71525f07189e97720688472172604879d49a5.patch
new file mode 100644
index 0000000000..3f285a1e52
--- /dev/null
+++ b/desktop/gnome-weather/4be71525f07189e97720688472172604879d49a5.patch
@@ -0,0 +1,26 @@
+From 4be71525f07189e97720688472172604879d49a5 Mon Sep 17 00:00:00 2001
+From: rvalue <i@rvalue.moe>
+Date: Fri, 17 Dec 2021 12:26:42 +0000
+Subject: [PATCH] Remove incorrect args for i18n.merge_file
+
+`i18n.merge_file` has been ignoring positional arguments for a time and
+explicitly rejects with error since meson 0.60.0
+---
+ data/meson.build | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index f6692b6..6981b96 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -59,7 +59,6 @@ endif
+ appdata_conf = configuration_data()
+ appdata_conf.set('app_id', weather_id)
+ appdata = i18n.merge_file(
+- 'appdata',
+ input: configure_file(
+ input: '@0@.appdata.xml.in.in'.format(default_id),
+ output: '@0@.appdata.xml.in'.format(default_id),
+--
+GitLab
+
diff --git a/desktop/gnome-weather/README b/desktop/gnome-weather/README
new file mode 100644
index 0000000000..9f618fe869
--- /dev/null
+++ b/desktop/gnome-weather/README
@@ -0,0 +1,2 @@
+A small application that allows you to monitor the current weather
+conditions for your city, or anywhere in the world.
diff --git a/desktop/gnome-weather/doinst.sh b/desktop/gnome-weather/doinst.sh
new file mode 100644
index 0000000000..401d987795
--- /dev/null
+++ b/desktop/gnome-weather/doinst.sh
@@ -0,0 +1,15 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
+if [ -e usr/share/glib-2.0/schemas ]; then
+ if [ -x /usr/bin/glib-compile-schemas ]; then
+ /usr/bin/glib-compile-schemas usr/share/glib-2.0/schemas >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/gnome-weather/gnome-weather.SlackBuild b/desktop/gnome-weather/gnome-weather.SlackBuild
new file mode 100644
index 0000000000..7bf10b2780
--- /dev/null
+++ b/desktop/gnome-weather/gnome-weather.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/bash
+
+# Slackware build script for gnome-weather
+
+# Copyright 2022 Bob Funk Winnipeg Canada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=gnome-weather
+VERSION=${VERSION:-41.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Patch data/meson.build to remove positional argument that causes
+# FTB with meson 0.60.0 or newer (i.e. fixes building on -current):
+patch -Np1 -i $CWD/4be71525f07189e97720688472172604879d49a5.patch
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}"
+ DESTDIR=$PKG $NINJA install
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.md NEWS README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/gnome-weather/gnome-weather.info b/desktop/gnome-weather/gnome-weather.info
new file mode 100644
index 0000000000..57489a442f
--- /dev/null
+++ b/desktop/gnome-weather/gnome-weather.info
@@ -0,0 +1,10 @@
+PRGNAM="gnome-weather"
+VERSION="41.0"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-weather"
+DOWNLOAD="https://download.gnome.org/sources/gnome-weather/41/gnome-weather-41.0.tar.xz"
+MD5SUM="03a4fba5f210a08dbae6d0f7806e733d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="geoclue2 libhandy libgweather"
+MAINTAINER="Bob Funk"
+EMAIL="bobfunk11@gmail.com"
diff --git a/desktop/gnome-weather/slack-desc b/desktop/gnome-weather/slack-desc
new file mode 100644
index 0000000000..448e3216a5
--- /dev/null
+++ b/desktop/gnome-weather/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gnome-weather: gnome-weather (GNOME Weather)
+gnome-weather:
+gnome-weather: Monitor the current weather conditions for your city, or anywhere in
+gnome-weather: the world.
+gnome-weather:
+gnome-weather:
+gnome-weather:
+gnome-weather:
+gnome-weather:
+gnome-weather: https://gitlab.gnome.org/GNOME/gnome-weather
+gnome-weather: