summaryrefslogtreecommitdiffstats
path: root/desktop/nwg-hello
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/nwg-hello')
-rw-r--r--desktop/nwg-hello/README11
-rw-r--r--desktop/nwg-hello/nwg-hello.SlackBuild117
-rw-r--r--desktop/nwg-hello/nwg-hello.info10
-rw-r--r--desktop/nwg-hello/nwg-hello.json23
-rw-r--r--desktop/nwg-hello/slack-desc19
5 files changed, 180 insertions, 0 deletions
diff --git a/desktop/nwg-hello/README b/desktop/nwg-hello/README
new file mode 100644
index 0000000000..0002ff6f17
--- /dev/null
+++ b/desktop/nwg-hello/README
@@ -0,0 +1,11 @@
+nwg-hello (GTK3-based greeter for greetd)
+
+ - Multi-monitor support with gtk-layer-shell,
+ - multi-language support,
+ - background & style customization with css,
+ - automatic selection of the last used session and user,
+ - support for setting environment variables.
+
+To enable nwg-hello you must setup 'greetd' to load on boot. Then copy
+'/etc/greetd/config.toml' to '/etc/greetd/greetd.conf' and change the
+'command' entry to be 'sway -c /etc/nwg-hello/sway-config'
diff --git a/desktop/nwg-hello/nwg-hello.SlackBuild b/desktop/nwg-hello/nwg-hello.SlackBuild
new file mode 100644
index 0000000000..527b499975
--- /dev/null
+++ b/desktop/nwg-hello/nwg-hello.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/bash
+#
+# Slackware build script for nwg-hello
+#
+# Copyright 2023-2024 Jay Lanagan (j@lngn.net), Detroit, MI, USA.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nwg-hello
+VERSION=${VERSION:-0.1.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# fix default sway conf
+sed -i -e 's,systemctl,loginctl,g' sway-config
+
+ install -Dm0644 -t $PKG/etc/nwg-hello/ nwg-hello-default.json
+ install -Dm0644 -t $PKG/etc/nwg-hello/ nwg-hello-default.css
+ install -Dm0644 -t $PKG/etc/nwg-hello/ hyprland.conf
+ install -Dm0644 -t $PKG/etc/nwg-hello/ sway-config
+ install -Dm0644 -t $PKG/etc/nwg-hello/ README
+ install -Dm0644 -t $PKG/usr/share/nwg-hello/ nwg.jpg
+ install -Dm0644 -t $PKG/usr/share/nwg-hello/ img/*
+
+ install -d $PKG/var/cache/nwg-hello
+ install -Dm0644 -t $PKG/var/cache/nwg-hello cache.json -o greeter
+
+ python3 setup.py install --root="$PKG" --optimize=1
+
+# install default config file into package so things work
+# auto-magically upon install
+install -Dm0644 -t $PKG/etc/nwg-hello/nwg-hello.json $CWD/nwg-hello.json
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README* \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/nwg-hello/nwg-hello.info b/desktop/nwg-hello/nwg-hello.info
new file mode 100644
index 0000000000..90162c5fe8
--- /dev/null
+++ b/desktop/nwg-hello/nwg-hello.info
@@ -0,0 +1,10 @@
+PRGNAM="nwg-hello"
+VERSION="0.1.10"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-hello/"
+DOWNLOAD="https://github.com/nwg-piotr/nwg-hello/archive/v0.1.10/nwg-hello-0.1.10.tar.gz"
+MD5SUM="c92985de4468818004d8b4d205efb124"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gtk-layer-shell greetd"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/desktop/nwg-hello/nwg-hello.json b/desktop/nwg-hello/nwg-hello.json
new file mode 100644
index 0000000000..a92b2ebfb0
--- /dev/null
+++ b/desktop/nwg-hello/nwg-hello.json
@@ -0,0 +1,23 @@
+{
+ "session_dirs": [
+ "/usr/share/wayland-sessions",
+ "/usr/share/xsessions"
+ ],
+ "custom_sessions": [
+ {
+ "name": "Shell",
+ "exec": "/bin/bash"
+ }
+ ],
+ "monitor_nums": [],
+ "delay_secs": 1,
+ "cmd-sleep": "loginctl suspend",
+ "cmd-reboot": "loginctl reboot",
+ "cmd-poweroff": "loginctl poweroff",
+ "gtk-theme": "Adwaita",
+ "gtk-icon-theme": "",
+ "gtk-cursor-theme": "",
+ "prefer-dark-theme": true,
+ "lang": "",
+ "env-vars": []
+} \ No newline at end of file
diff --git a/desktop/nwg-hello/slack-desc b/desktop/nwg-hello/slack-desc
new file mode 100644
index 0000000000..61c23425a0
--- /dev/null
+++ b/desktop/nwg-hello/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+nwg-hello: nwg-hello (GTK3-based greeter for greetd)
+nwg-hello:
+nwg-hello: Multi-monitor support with gtk-layer-shell,
+nwg-hello: multi-language support,
+nwg-hello: background & style customization with css,
+nwg-hello: automatic selection of the last used session and user,
+nwg-hello: support for setting environment variables.
+nwg-hello:
+nwg-hello: Homepage: https://github.com/nwg-piotr/nwg-hello
+nwg-hello:
+nwg-hello: