summaryrefslogtreecommitdiffstats
path: root/desktop/nwg-panel
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/nwg-panel')
-rw-r--r--desktop/nwg-panel/README4
-rw-r--r--desktop/nwg-panel/doinst.sh3
-rw-r--r--desktop/nwg-panel/loginctl.patch85
-rw-r--r--desktop/nwg-panel/nwg-panel.SlackBuild108
-rw-r--r--desktop/nwg-panel/nwg-panel.info10
-rw-r--r--desktop/nwg-panel/slack-desc19
6 files changed, 229 insertions, 0 deletions
diff --git a/desktop/nwg-panel/README b/desktop/nwg-panel/README
new file mode 100644
index 0000000000..a4a583cf5b
--- /dev/null
+++ b/desktop/nwg-panel/README
@@ -0,0 +1,4 @@
+nwg-panel (gtk wayland based panel)
+
+Combining features of Waybar and tint2, nwg-panel has a total of
+12 modules for desktop settings configuration for the nwg-shell.
diff --git a/desktop/nwg-panel/doinst.sh b/desktop/nwg-panel/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/nwg-panel/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/nwg-panel/loginctl.patch b/desktop/nwg-panel/loginctl.patch
new file mode 100644
index 0000000000..9ba71211bd
--- /dev/null
+++ b/desktop/nwg-panel/loginctl.patch
@@ -0,0 +1,85 @@
+--- a/nwg_panel/config.py
++++ b/nwg_panel/config.py
+@@ -86,8 +86,8 @@
+ "menu-start-settings": {
+ "cmd-lock": "swaylock -f -c 000000",
+ "cmd-logout": "swaymsg exit",
+- "cmd-restart": "systemctl reboot",
+- "cmd-shutdown": "systemctl -i poweroff",
++ "cmd-restart": "loginctl reboot",
++ "cmd-shutdown": "loginctl poweroff",
+ "autohide": True,
+ "file-manager": "thunar",
+ "height": 0,
+@@ -2142,8 +2142,8 @@
+ defaults = {
+ "cmd-lock": "swaylock -f -c 000000",
+ "cmd-logout": "swaymsg exit",
+- "cmd-restart": "systemctl reboot",
+- "cmd-shutdown": "systemctl -i poweroff",
++ "cmd-restart": "loginctl reboot",
++ "cmd-shutdown": "loginctl poweroff",
+ "autohide": True,
+ "file-manager": "thunar",
+ "height": 0,
+@@ -3493,11 +3493,11 @@
+ },
+ {
+ "name": "Reboot",
+- "cmd": "systemctl reboot"
++ "cmd": "loginctl reboot"
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "systemctl -i poweroff"
++ "cmd": "loginctl poweroff"
+ }
+ ]
+ }
+
+--- a/nwg_panel/config/config
++++ b/nwg_panel/config/config
+@@ -64,11 +64,11 @@
+ },
+ {
+ "name": "Reboot",
+- "cmd": "systemctl reboot"
++ "cmd": "loginctl reboot"
+ },
+ {
+ "name": "Shutdown",
+- "cmd": "systemctl -i poweroff"
++ "cmd": "loginctl poweroff"
+ }
+ ]
+ }
+
+--- a/nwg_panel/main.py
++++ b/nwg_panel/main.py
+@@ -643,8 +643,8 @@
+ defaults = {
+ "cmd-lock": "swaylock -f -c 000000",
+ "cmd-logout": "swaymsg exit",
+- "cmd-restart": "systemctl reboot",
+- "cmd-shutdown": "systemctl -i poweroff",
++ "cmd-restart": "loginctl reboot",
++ "cmd-shutdown": "loginctl poweroff",
+ "autohide": True,
+ "file-manager": "thunar",
+ "height": 0,
+
+--- a/nwg_panel/modules/menu_start.py
++++ b/nwg_panel/modules/menu_start.py
+@@ -33,9 +33,9 @@
+ cmd += " -cmd-lock '{}'".format(self.settings["cmd-lock"])
+ if self.settings["cmd-logout"] != "swaymsg exit":
+ cmd += " -cmd-logout '{}'".format(self.settings["cmd-logout"])
+- if self.settings["cmd-restart"] != "systemctl reboot":
++ if self.settings["cmd-restart"] != "loginctl reboot":
+ cmd += " -cmd-restart '{}'".format(self.settings["cmd-restart"])
+- if self.settings["cmd-shutdown"] != "systemctl -i poweroff":
++ if self.settings["cmd-shutdown"] != "loginctl poweroff":
+ cmd += " -cmd-shutdown '{}'".format(self.settings["cmd-shutdown"])
+ if self.settings["autohide"]:
+ cmd += " -d"
+
diff --git a/desktop/nwg-panel/nwg-panel.SlackBuild b/desktop/nwg-panel/nwg-panel.SlackBuild
new file mode 100644
index 0000000000..c6f8b8fa6d
--- /dev/null
+++ b/desktop/nwg-panel/nwg-panel.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/bash
+
+# Slackware build script for nwg-panel
+
+# Copyright 2023-2024 Jay Lanagan (j@lngn.net), Detroit, MI, USA.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nwg-panel
+VERSION=${VERSION:-0.9.32}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z || tar xvf $CWD/v$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+
+# fix reboot/shutdown commands in menu
+patch -Np1 -i $CWD/loginctl.patch || exit 1
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --optimize=1 --root=$PKG
+install -Dm0644 -t $PKG/usr/share/pixmaps *.svg
+install -Dm0644 -t $PKG/usr/share/applications *.desktop
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE *.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/nwg-panel/nwg-panel.info b/desktop/nwg-panel/nwg-panel.info
new file mode 100644
index 0000000000..9aaf5d1f03
--- /dev/null
+++ b/desktop/nwg-panel/nwg-panel.info
@@ -0,0 +1,10 @@
+PRGNAM="nwg-panel"
+VERSION="0.9.32"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-panel/"
+DOWNLOAD="https://github.com/nwg-piotr/nwg-panel/archive/v0.9.32/nwg-panel-0.9.32.tar.gz"
+MD5SUM="e1b7226b286ac0ca97cf690eb8da8e5d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="brightnessctl nwg-icon-picker playerctl python3-psutil i3ipc python3-dasbus python3-netifaces SwayNotificationCenter wlr-randr ddcutil"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/desktop/nwg-panel/slack-desc b/desktop/nwg-panel/slack-desc
new file mode 100644
index 0000000000..f6a4d3f74d
--- /dev/null
+++ b/desktop/nwg-panel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+nwg-panel: nwg-panel (GTK Wayland-based panel)
+nwg-panel:
+nwg-panel: Combining features of Waybar and tint2, nwg-panel has a total of
+nwg-panel: 12 modules for desktop settings configuration for the nwg-shell.
+nwg-panel:
+nwg-panel: Homepage: https://github.com/nwg-piotr/nwg-panel
+nwg-panel:
+nwg-panel:
+nwg-panel:
+nwg-panel:
+nwg-panel: