summaryrefslogtreecommitdiffstats
path: root/desktop/polybar/polybar.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'desktop/polybar/polybar.SlackBuild')
-rw-r--r--desktop/polybar/polybar.SlackBuild42
1 files changed, 26 insertions, 16 deletions
diff --git a/desktop/polybar/polybar.SlackBuild b/desktop/polybar/polybar.SlackBuild
index b86a3cabea..3dd1cd15fb 100644
--- a/desktop/polybar/polybar.SlackBuild
+++ b/desktop/polybar/polybar.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for polybar
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=polybar
-VERSION=${VERSION:-3.3.1}
+VERSION=${VERSION:-3.5.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -63,9 +73,9 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
# Extract the Git modules to lib
-for mod in i3ipcpp-0.7.0 xpp-1.4.0; do
+for mod in i3ipcpp-0.7.0 xpp-20210303_7a9960b; do
rm -rf lib/${mod%-*}
- tar xvf $CWD/$mod.tar.gz
+ tar xvf $CWD/$mod.tar.?z
mv $mod lib/${mod%-*}
done
chown -R root:root .
@@ -75,27 +85,27 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Fixes install location
-sed -i -e '/share\/doc\/polybar/s/share\///' doc/CMakeLists.txt
-sed -i -e "/DESTINATION doc\/polybar/s/polybar/$PRGNAM-$VERSION/" doc/CMakeLists.txt
-sed -i -e '/share\/man\/man1/s/share\///' man/CMakeLists.txt
-
# Fixes version
-sed -i -e "/execute_process(COMMAND git describe --tags --dirty=-git/s/git.*/echo $VERSION/" include/CMakeLists.txt
+sed -i -e "/execute_process(COMMAND git describe --tags --dirty=-git/s/git.*/echo $VERSION/" include/CMakeLists.txt || exit 1
+
+export PYTHON=python3
mkdir -p build
cd build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -Wno-error=implicit-fallthrough -Wno-error=stringop-truncation -Wno-error=deprecated-copy" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DCMAKE_INSTALL_DOCDIR=/usr/doc/$PRGNAM-$VERSION \
-DCMAKE_BUILD_TYPE=Release ..
- make -j1
+ make
make install/strip DESTDIR=$PKG
cd ..
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+find $PKG/usr/man -type f -exec gzip -9 {} \; || true
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE README.md SUPPORT.md $PKG/usr/doc/$PRGNAM-$VERSION
@@ -105,4 +115,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE