summaryrefslogtreecommitdiffstats
path: root/development/cppcheck/install-translations-in-filesdir-lang.diff
diff options
context:
space:
mode:
Diffstat (limited to 'development/cppcheck/install-translations-in-filesdir-lang.diff')
-rw-r--r--development/cppcheck/install-translations-in-filesdir-lang.diff16
1 files changed, 16 insertions, 0 deletions
diff --git a/development/cppcheck/install-translations-in-filesdir-lang.diff b/development/cppcheck/install-translations-in-filesdir-lang.diff
new file mode 100644
index 0000000000..63c7f0d5e8
--- /dev/null
+++ b/development/cppcheck/install-translations-in-filesdir-lang.diff
@@ -0,0 +1,16 @@
+Description: Install the translations in $FILESDIR/lang instead of /usr/bin
+Author: Joachim Reichel <reichel@debian.org>
+
+Index: cppcheck/gui/CMakeLists.txt
+===================================================================
+--- cppcheck.orig/gui/CMakeLists.txt
++++ cppcheck/gui/CMakeLists.txt
+@@ -51,7 +51,7 @@ if (BUILD_GUI)
+ endif()
+
+ install(TARGETS cppcheck-gui RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
+- install(FILES ${qms} DESTINATION ${CMAKE_INSTALL_FULL_BINDIR} COMPONENT applications)
++ install(FILES ${qms} DESTINATION ${FILESDIR}/lang COMPONENT applications)
+
+ install(FILES cppcheck-gui.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications)
+