summaryrefslogtreecommitdiffstats
path: root/development/hhvm
diff options
context:
space:
mode:
Diffstat (limited to 'development/hhvm')
-rw-r--r--development/hhvm/0001-Link-static-libiberty.patch24
-rw-r--r--development/hhvm/README59
-rw-r--r--development/hhvm/doinst.sh20
-rw-r--r--development/hhvm/etc/php.ini1
-rw-r--r--development/hhvm/etc/rc.hhvm163
-rw-r--r--development/hhvm/etc/server.ini9
-rw-r--r--development/hhvm/hhvm.SlackBuild159
-rw-r--r--development/hhvm/hhvm.info26
-rw-r--r--development/hhvm/slack-desc19
9 files changed, 0 insertions, 480 deletions
diff --git a/development/hhvm/0001-Link-static-libiberty.patch b/development/hhvm/0001-Link-static-libiberty.patch
deleted file mode 100644
index 1f35da35d7..0000000000
--- a/development/hhvm/0001-Link-static-libiberty.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-libiberty is part of GCC and is provided only statically on Slackware. We
-patch CMake to use it.
-Patches CMake to avoid downloading during the build since we use prefetched
-sources.
---- a/third-party/folly/CMakeLists.txt 2021-04-22 08:09:46.000000000 +0200
-+++ b/third-party/folly/CMakeLists.txt 2021-05-03 07:43:23.777873092 +0200
-@@ -298,3 +298,6 @@
- # Just assume we have sched.h
- target_compile_definitions(folly PUBLIC "FOLLY_HAVE_SCHED_H=1")
- endif()
-+
-+target_link_libraries(folly /usr/lib64/libiberty.a)
-+target_include_directories(folly PUBLIC /usr/include/libiberty)
---- a/third-party/brotli/CMakeLists.txt 2021-04-22 08:09:46.000000000 +0200
-+++ b/third-party/brotli/CMakeLists.txt 2021-05-03 06:21:46.202704488 +0200
-@@ -6,8 +6,6 @@
- # version.
- ExternalProject_Add(
- bundled_brotli
-- GIT_REPOSITORY https://github.com/google/brotli
-- GIT_TAG 4b5771bee7995d3d606221caa455c044d80434df
- CMAKE_ARGS
- -DCMAKE_INSTALL_PREFIX=<INSTALL_DIR>
- -DCMAKE_INSTALL_INCLUDEDIR=include
diff --git a/development/hhvm/README b/development/hhvm/README
deleted file mode 100644
index 2467669770..0000000000
--- a/development/hhvm/README
+++ /dev/null
@@ -1,59 +0,0 @@
-HHVM is an open-source virtual machine designed for executing programs
-written in Hack and PHP. HHVM uses a just-in-time (JIT) compilation
-approach to achieve superior performance while maintaining the
-development flexibility that PHP provides.
-
-Hack is a programming language for HHVM. Hack reconciles the fast
-development cycle of a dynamically typed language with the discipline
-provided by static typing, while adding many features commonly found
-in other modern programming languages.
-
-Please note that HHVM is unsupported on 32-bit OSes and there are no
-current plans to ever add support.
-
-In order to start HHVM at boot and stop it properly at shutdown,
-make sure rc.hhvm is executable and add the following lines to
-your rc.d scripts:
-
- /etc/rc.d/rc.local
- ==================
- # Startup HHVM
- if [ -x /etc/rc.d/rc.hhvm ]; then
- /etc/rc.d/rc.hhvm start
- fi
-
- /etc/rc.d/rc.local_shutdown
- ===========================
- # Stop HHVM
- if [ -x /etc/rc.d/rc.hhvm ]; then
- /etc/rc.d/rc.hhvm stop
- fi
-
-HHVM ships an integrated web server, proxygen, which listens on port
-9000 (though you can configure proxygen to make use of a different
-port): https://docs.hhvm.com/hhvm/basic-usage/proxygen.
-
-Alternatively to reverse proxy, FastCGI is available, which uses Unix
-sockets by default. If your web server isn't Apache make sure it has
-write access to the socket file. You can create a new group and add
-your web server user to this group or just use the main group of your
-web server and start HHVM as following:
-
- hhvm_GROUP=apache /etc/rc.d/rc.hhvm start
-
-See https://docs.hhvm.com/hhvm/advanced-usage/fastCGI.
-
-To start a project you have to configure the type checker as well.
-See the official documentation:
-https://docs.hhvm.com/hack/getting-started/getting-started
-
-Basically you create an empty .hhconfig file in the root dir of your
-project:
-
- touch .hhconfig
-
-and run:
-
- hh_client
-
-Happy Hacking!
diff --git a/development/hhvm/doinst.sh b/development/hhvm/doinst.sh
deleted file mode 100644
index 6979f0cdcf..0000000000
--- a/development/hhvm/doinst.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-config() {
- NEW="$1"
- OLD="`dirname $NEW`/`basename $NEW .new`"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "`cat $OLD | md5sum`" = "`cat $NEW | md5sum`" ]; then # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-# Keep same perms on rc.hhvm.new:
-if [ -e etc/rc.d/rc.hhvm ]; then
- cp -a etc/rc.d/rc.hhvm etc/rc.d/rc.hhvm.new.incoming
- cat etc/rc.d/rc.hhvm.new > etc/rc.d/rc.hhvm.new.incoming
- mv etc/rc.d/rc.hhvm.new.incoming etc/rc.d/rc.hhvm.new
-fi
-config etc/rc.d/rc.hhvm.new
-config etc/hhvm/server.ini.new
-config etc/hhvm/php.ini.new
diff --git a/development/hhvm/etc/php.ini b/development/hhvm/etc/php.ini
deleted file mode 100644
index 5004b9fb11..0000000000
--- a/development/hhvm/etc/php.ini
+++ /dev/null
@@ -1 +0,0 @@
-extension_dir = /usr/lib64/hhvm/extensions
diff --git a/development/hhvm/etc/rc.hhvm b/development/hhvm/etc/rc.hhvm
deleted file mode 100644
index 073e973a03..0000000000
--- a/development/hhvm/etc/rc.hhvm
+++ /dev/null
@@ -1,163 +0,0 @@
-#!/bin/sh
-#
-### BEGIN INIT INFO
-# Provides: hhvm
-# Required-Start: $remote_fs $network
-# Required-Stop: $remote_fs $network
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
-# Description: Starts the HHVM daemon
-### END INIT INFO
-
-PIDFILE=/var/run/hhvm/pid
-hhvm_SOCKET=/var/run/hhvm/sock
-hhvm_GROUP=${hhvm_GROUP:-apache}
-CONFIG_FILE="/etc/hhvm/server.ini"
-SYSTEM_CONFIG_FILE="/etc/hhvm/php.ini"
-
-DAEMON_ARGS="--config ${SYSTEM_CONFIG_FILE} \
- --config ${CONFIG_FILE} \
- --user ${hhvm_GROUP} \
- -vPidFile=${PIDFILE}"
-
-do_stop () {
- try=0
-
- if [ ! -r $2 ]; then
- echo "warning, no pid file found - HHVM is not running?"
- exit 1
- fi
-
- PID=$(cat $2)
- kill $1 $PID
-
- # Waiting for HHVM to shutdown
- while test $try -lt 35
- do
- if ps -p $PID | grep -q $PID
- then
- echo -n .
- try=$(expr $try + 1)
- sleep 1
- else
- try=''
- break
- fi
- done
-
- if [ -n "$try" ]
- then
- echo " failed. Use force-quit"
- exit 1
- else
- rm -f $2
- echo " done"
- fi
-}
-
-wait_for_pid () {
- try=0
-
- while test $try -lt 35
- do
- if [ -f "$1" ] ; then
- try=''
- break
- fi
-
- echo -n .
- try=$(expr $try + 1)
- sleep 1
- done
-
-}
-
-case "$1" in
- start)
- echo -n "Starting HHVM "
-
- if [ -r $PIDFILE ]; then
- echo "warning, pid file found - HHVM is already running?"
- exit 1
- fi
-
- mkdir -p $(dirname ${PIDFILE}) $(dirname ${hhvm_SOCKET})
- chown apache:apache $(dirname ${PIDFILE})
-
- echo
- /usr/bin/hhvm --mode daemon $DAEMON_ARGS
- if [ "$?" != 0 ]
- then
- echo "Failed"
- exit 1
- fi
-
- wait_for_pid $PIDFILE
-
- if [ -n "$try" ] ; then
- echo " failed"
- exit 1
- fi
-
- # Set the socket permissions if HHVM uses UDS
- if [ -S "$hhvm_SOCKET" ]
- then
- chgrp $hhvm_GROUP $hhvm_SOCKET
- fi
-
- echo " done"
- ;;
-
- stop)
- echo -n "Stopping HHVM "
-
- do_stop -QUIT $PIDFILE
- ;;
-
- force-quit)
- echo -n "Terminating HHVM "
-
- do_stop -TERM $PIDFILE
- ;;
-
- status)
- if [ ! -r $PIDFILE ]
- then
- echo "HHVM is stopped"
- exit 0
- fi
-
- PID=$(cat $PIDFILE)
- if ps -p $PID | grep -q $PID
- then
- echo "HHVM (pid $PID) is running..."
- else
- echo "HHVM dead but pid file exists"
- fi
- ;;
-
- restart)
- sh $0 stop
- sh $0 start
- ;;
-
- reload)
- echo -n "Reload service HHVM "
-
- if [ ! -r $PIDFILE ]
- then
- echo "warning, no pid file found - HHVM is not running?"
- exit 1
- fi
-
- kill -USR2 $(cat $PIDFILE)
-
- echo " done"
- ;;
-
- *)
- echo "Usage: $0 {start|stop|status|restart|reload|force-quit}" >&2
- exit 1
- ;;
-
-esac
diff --git a/development/hhvm/etc/server.ini b/development/hhvm/etc/server.ini
deleted file mode 100644
index ce240979d4..0000000000
--- a/development/hhvm/etc/server.ini
+++ /dev/null
@@ -1,9 +0,0 @@
-pid = /var/run/hhvm/pid
-
-;hhvm.server.file_socket = /var/run/hhvm/sock
-hhvm.server.port = 9000
-hhvm.server.type = proxygen
-hhvm.server.default_document = index.hh
-hhvm.log.use_log_file = true
-hhvm.log.file = /var/log/hhvm/error.log
-hhvm.repo.central.path = /var/run/hhvm/hhvm.hhbc
diff --git a/development/hhvm/hhvm.SlackBuild b/development/hhvm/hhvm.SlackBuild
deleted file mode 100644
index cbaa474322..0000000000
--- a/development/hhvm/hhvm.SlackBuild
+++ /dev/null
@@ -1,159 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for HHVM
-
-# Copyright 2015-2021 Eugene Wissner, Dachau, Germany
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=hhvm
-VERSION=${VERSION:-4.104.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-OPAM_STAMP="221708b"
-CARGO_BUILD="1"
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- echo "$ARCH is not supported."
- exit 1
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar Jxvf $CWD/$PRGNAM-$VERSION.tar.xz
-cd $PRGNAM-$VERSION
-
-mkdir -p hphp/hack/facebook third-party/brotli/bundled_brotli-prefix/src
-
-mkdir -p hphp/hack/_build/opam
-tar Jxvf $CWD/hack-switch-$OPAM_STAMP.tar.xz -C hphp/hack/_build/opam
-# hhvm prepares an opam switch (an isolated envrionment with a specific OCaml
-# compiler version) during the build, it downloads and builds all dependencies.
-# To avoid doing this at runtime, I provide a prebuilt switch. Unfortunately
-# it contains references to absolute paths it has been built in. Therefore if
-# the user doesn't build in the standard directory, we put a link there, so
-# that opam can find binaries.
-if [ "$TMP" != '/tmp/SBo' ]
-then
- rm -rf /tmp/SBo/hhvm-$VERSION/hphp/hack/_build/opam
- mkdir -p /tmp/SBo/hhvm-$VERSION/hphp/hack/_build/opam
- ln -s $TMP/$PRGNAM-$VERSION/hphp/hack/_build/opam/hack-switch \
- /tmp/SBo/hhvm-$VERSION/hphp/hack/_build/opam/hack-switch
-fi
-
-tar Jxvf $CWD/cargo-home-$CARGO_BUILD.tar.xz -C hphp/hack
-tar Jxvf $CWD/brotli-4b5771be.tar.xz -C third-party/brotli/bundled_brotli-prefix/src
-
-install -m 0755 -D $CWD/opam-2.0.7-x86_64-linux \
- third-party/opam/opamDownload-prefix/src/opam-2.0.7-x86_64-linux
-install -m 0644 -D $CWD/rust-1.43.0-x86_64-unknown-linux-gnu.tar.gz \
- third-party/rustc/bundled_rust-prefix/src/rust-1.43.0-x86_64-unknown-linux-gnu.tar.gz
-install -m 0644 -D $CWD/fmt-6.1.2.zip third-party/fmt/fmt-prefix/src/fmt-6.1.2.zip
-install -m 0644 -D $CWD/fb-prod8-202010.tar.gz \
- third-party/fb-mysql/bundled_fbmysqlclient-prefix/src/fb-prod8-202010.tar.gz
-
-# The working directory is hphp/hack.
-cat << EOF > hphp/hack/facebook/fetch_opam2_repo_hack.sh
-#!/bin/sh
-cp $CWD/index-$OPAM_STAMP.tar.gz facebook/
-echo facebook/index-$OPAM_STAMP
-EOF
-chmod 0755 hphp/hack/facebook/fetch_opam2_repo_hack.sh
-
-patch -p1 --verbose -i $CWD/0001-Link-static-libiberty.patch
-
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-export CMAKE_PREFIX_PATH=`pwd`
-cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_STANDARD=17 \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
- -DENABLE_MCROUTER=false \
- -DENABLE_EXTENSION_IMAGICK=false \
- -DNON_DISTRIBUTABLE_BUILD=true \
- -DENABLE_LD_GOLD=true \
- -DUSE_JEMALLOC=true \
- -DFORCE_BUNDLED_LZ4=OFF \
- -DMYSQL_UNIX_SOCK_ADDR=/var/run/mysqld/mysqld.sock \
- -DCMAKE_BUILD_TYPE=Release .
-make || make -j1
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/man
-mv hphp/doc/man $PKG/usr/man/man1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-install -m 644 -D $CWD/etc/rc.hhvm $PKG/etc/rc.d/rc.hhvm.new
-install -m 644 -D $CWD/etc/server.ini $PKG/etc/hhvm/server.ini.new
-install -m 644 -D $CWD/etc/php.ini $PKG/etc/hhvm/php.ini.new
-
-mkdir -p $PKG/var/log/hhvm $PKG/usr/lib64/hhvm/extensions
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md LICENSE* hphp/doc/* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/hhvm/hhvm.info b/development/hhvm/hhvm.info
deleted file mode 100644
index 229a8e4000..0000000000
--- a/development/hhvm/hhvm.info
+++ /dev/null
@@ -1,26 +0,0 @@
-PRGNAM="hhvm"
-VERSION="4.104.1"
-HOMEPAGE="https://hhvm.com/"
-DOWNLOAD="UNSUPPORTED"
-MD5SUM=""
-DOWNLOAD_x86_64="https://download.dlackware.com/hosted-sources/hhvm/hhvm-4.104.1.tar.xz \
- https://static.rust-lang.org/dist/rust-1.43.0-x86_64-unknown-linux-gnu.tar.gz \
- https://download.dlackware.com/hosted-sources/hhvm/opam-2.0.7-x86_64-linux \
- https://download.dlackware.com/hosted-sources/hhvm/brotli-4b5771be.tar.xz \
- https://download.dlackware.com/hosted-sources/hhvm/fmt-6.1.2.zip \
- https://download.dlackware.com/hosted-sources/hhvm/cargo-home-1.tar.xz \
- https://download.dlackware.com/hosted-sources/hhvm/index-221708b.tar.gz \
- https://download.dlackware.com/hosted-sources/hhvm/hack-switch-221708b.tar.xz \
- https://download.dlackware.com/hosted-sources/hhvm/fb-prod8-202010.tar.gz"
-MD5SUM_x86_64="0bddb92bbf45f8a7d2ef84256293ef63 \
- c1cb2b3d0c9edb4b61b01ba6b090d01b \
- b4398cb8403252321510fadd87a4a265 \
- 7553d4e66d8d5d78af3e53b1083f17b4 \
- 5ec643b082a34254ad07136e7cbd4220 \
- 38b0384806e3415c0a7c42e4a0facf5b \
- c1c35bc5a0198f25be9c13cb88c7df2f \
- 95ef57a2272d3405257dff3395220847 \
- f5f484685fe2a7cdaa1d3f3c107bb23b"
-REQUIRES="tbb glog libdwarf libmemcached double-conversion"
-MAINTAINER="Eugene Wissner"
-EMAIL="belka@caraus.de"
diff --git a/development/hhvm/slack-desc b/development/hhvm/slack-desc
deleted file mode 100644
index 9d6bbdf91e..0000000000
--- a/development/hhvm/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-hhvm: hhvm (a virtual machine designed for executing Hack and PHP)
-hhvm:
-hhvm: HHVM uses a just-in-time (JIT) compilation approach to achieve
-hhvm: superior performance while maintaining the development flexibility
-hhvm: that PHP provides.
-hhvm:
-hhvm: Hack is a programming language for HHVM.
-hhvm:
-hhvm:
-hhvm: Homepage: https://hhvm.com/
-hhvm: