summaryrefslogtreecommitdiffstats
path: root/development/jupyter_client/jupyter_client.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'development/jupyter_client/jupyter_client.SlackBuild')
-rw-r--r--development/jupyter_client/jupyter_client.SlackBuild50
1 files changed, 6 insertions, 44 deletions
diff --git a/development/jupyter_client/jupyter_client.SlackBuild b/development/jupyter_client/jupyter_client.SlackBuild
index d998ac775a..6b936dd0c6 100644
--- a/development/jupyter_client/jupyter_client.SlackBuild
+++ b/development/jupyter_client/jupyter_client.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for jupyter_client
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jupyter_client
-VERSION=${VERSION:-7.3.4}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-7.4.9}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -80,35 +63,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from setuptools import setup, find_packages
-setup(name='${PRGNAM}',
- version='${VERSION}',
- packages=find_packages(exclude=["docs", "docs.*", "tests", "tests.*"]),
- package_data={'': ['*']},
- entry_points={
- 'console_scripts': [
- 'jupyter-kernelspec = jupyter_client.kernelspecapp:KernelSpecApp.launch_instance',
- 'jupyter-run = jupyter_client.runapp:RunApp.launch_instance',
- 'jupyter-kernel = jupyter_client.kernelapp:main',
- ],
- 'jupyter_client.kernel_provisioners': [
- 'local-provisioner = jupyter_client.provisioning:LocalProvisioner',
- ],
- },
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.md README.md RELEASING.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install