summaryrefslogtreecommitdiffstats
path: root/development/nodeenv
diff options
context:
space:
mode:
Diffstat (limited to 'development/nodeenv')
-rw-r--r--development/nodeenv/README14
-rw-r--r--development/nodeenv/nodeenv.SlackBuild84
-rw-r--r--development/nodeenv/nodeenv.info10
-rw-r--r--development/nodeenv/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/development/nodeenv/README b/development/nodeenv/README
new file mode 100644
index 0000000000..43330ff901
--- /dev/null
+++ b/development/nodeenv/README
@@ -0,0 +1,14 @@
+Node.js virtual environment
+===========================
+
+``nodeenv`` (node.js virtual environment) is a tool to create isolated
+node.js environments.
+
+It creates an environment that has its own installation directories,
+that doesn't share libraries with other node.js virtual environments.
+
+Also the new environment can be integrated with the environment which
+was built by virtualenv_ (python).
+
+
+
diff --git a/development/nodeenv/nodeenv.SlackBuild b/development/nodeenv/nodeenv.SlackBuild
new file mode 100644
index 0000000000..e72eb4c1bb
--- /dev/null
+++ b/development/nodeenv/nodeenv.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/bash
+
+# Slackware build script for nodeenv
+
+# Author: Lockywolf, 2023
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nodeenv
+SRCNAM=nodeenv
+VERSION=${VERSION:-1.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd "$SRCNAM-$VERSION"
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --optimize=1 --root="$PKG"
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE README.rst CHANGES README.ru.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/nodeenv/nodeenv.info b/development/nodeenv/nodeenv.info
new file mode 100644
index 0000000000..4f9bfc4c59
--- /dev/null
+++ b/development/nodeenv/nodeenv.info
@@ -0,0 +1,10 @@
+PRGNAM="nodeenv"
+VERSION="1.6.0"
+HOMEPAGE="http://ekalinin.github.io/nodeenv/"
+DOWNLOAD="https://github.com/ekalinin/nodeenv/archive/1.6.0/nodeenv-1.6.0.tar.gz"
+MD5SUM="77ca9ce25841f3aafec7b702e8bfb5d5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.nodeenv_2023-05-11@lockywolf.net"
diff --git a/development/nodeenv/slack-desc b/development/nodeenv/slack-desc
new file mode 100644
index 0000000000..54ba27c419
--- /dev/null
+++ b/development/nodeenv/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+nodeenv: nodeenv (Node.js virtual environment)
+nodeenv:
+nodeenv: nodeenv is a tool to create isolated node.js environments, similar
+nodeenv: to python's venv and virtualenv.
+nodeenv:
+nodeenv:
+nodeenv:
+nodeenv:
+nodeenv:
+nodeenv:
+nodeenv: