summaryrefslogtreecommitdiffstats
path: root/development/rgbds
diff options
context:
space:
mode:
Diffstat (limited to 'development/rgbds')
-rw-r--r--development/rgbds/README9
-rw-r--r--development/rgbds/rgbds.SlackBuild104
-rw-r--r--development/rgbds/rgbds.info10
-rw-r--r--development/rgbds/slack-desc19
4 files changed, 142 insertions, 0 deletions
diff --git a/development/rgbds/README b/development/rgbds/README
new file mode 100644
index 0000000000..e0e489daec
--- /dev/null
+++ b/development/rgbds/README
@@ -0,0 +1,9 @@
+rgbds (cross assembler targeting Nintendo Game Boy and Game Boy Color)
+
+RGBDS (Rednex Game Boy Development System) is a free assembler/linker
+package for the Game Boy and Game Boy Color. It consists of rgbasm
+(assembler), rgblink (linker), rgbfix (checksum/header fixer), and
+rgbgfx (PNG-to-Game Boy graphics converter).
+
+This is a fork of the original RGBDS which aims to make the programs
+more like other UNIX tools.
diff --git a/development/rgbds/rgbds.SlackBuild b/development/rgbds/rgbds.SlackBuild
new file mode 100644
index 0000000000..15660c7169
--- /dev/null
+++ b/development/rgbds/rgbds.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/bash
+
+# Slackware build script for rgbds
+
+# Written by B. Watson (urchlay@slackware.uk)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20240209 bkw: update for v0.7.0
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=rgbds
+VERSION=${VERSION:-0.7.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# Fix hardcoded man page path, and do not install tests/ binaries to
+# $PKG/$PKG (ugh).
+sed -i 's,share/man,man,' CMakeLists.txt
+sed -i '/^install(/s,\(DESTINATION\).*,\1 bin),' test/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMANDIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+gzip -9 $PKG/usr/man/man*/*
+
+# bash and zsh completions are a nice extra, they seem to work OK.
+BCOMP=$PKG/usr/share/bash-completion/completions
+ZCOMP=$PKG/usr/share/zsh/site-functions
+mkdir -p $BCOMP $ZCOMP
+for i in contrib/bash_compl/_*.bash; do
+ fname="$( basename $i | cut -d_ -f2 | cut -d. -f1 )"
+ cat $i > $BCOMP/$fname
+done
+install -m0644 contrib/zsh_compl/_* $ZCOMP
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC/contrib
+cp -a CONTRIB* LICENSE* README* RELEASE* $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
+
+# no idea if this stuff is useful, put it in the doc dir.
+install -m0644 contrib/*.bash $PKGDOC/contrib
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/rgbds/rgbds.info b/development/rgbds/rgbds.info
new file mode 100644
index 0000000000..4b527ca2a8
--- /dev/null
+++ b/development/rgbds/rgbds.info
@@ -0,0 +1,10 @@
+PRGNAM="rgbds"
+VERSION="0.7.0"
+HOMEPAGE="https://github.com/gbdev/rgbds"
+DOWNLOAD="https://github.com/gbdev/rgbds/archive/v0.7.0/rgbds-0.7.0.tar.gz"
+MD5SUM="e73ca5f719ac18bd04fb626fd2c14332"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"
diff --git a/development/rgbds/slack-desc b/development/rgbds/slack-desc
new file mode 100644
index 0000000000..a15dc4bb2a
--- /dev/null
+++ b/development/rgbds/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rgbds: rgbds (cross assembler targeting Nintendo Game Boy and Game Boy Color)
+rgbds:
+rgbds: RGBDS (Rednex Game Boy Development System) is a free assembler/linker
+rgbds: package for the Game Boy and Game Boy Color. It consists of rgbasm
+rgbds: (assembler), rgblink (linker), rgbfix (checksum/header fixer), and
+rgbds: rgbgfx (PNG-to-Game Boy graphics converter).
+rgbds:
+rgbds: This is a fork of the original RGBDS which aims to make the programs
+rgbds: more like other UNIX tools.
+rgbds:
+rgbds: