summaryrefslogtreecommitdiffstats
path: root/games/jezzball-kazzmir/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/jezzball-kazzmir/Makefile')
-rw-r--r--games/jezzball-kazzmir/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/games/jezzball-kazzmir/Makefile b/games/jezzball-kazzmir/Makefile
new file mode 100644
index 0000000000..62fd93548c
--- /dev/null
+++ b/games/jezzball-kazzmir/Makefile
@@ -0,0 +1,16 @@
+PRGNAM=jezzball
+
+SRCS=$(wildcard src/*.cpp)
+OBJS=$(patsubst %.cpp,%.o,$(SRCS))
+
+CXX=g++
+OPTFLAGS=
+CXXFLAGS=$(OPTFLAGS) -Wno-write-strings $(shell allegro-config --cflags) $(shell libpng-config --cflags)
+LDFLAGS=$(shell allegro-config --libs) -ljpgalleg -lloadpng $(shell libpng-config --libs)
+
+all: $(PRGNAM)
+
+$(PRGNAM): $(OBJS)
+ $(CXX) -o $(PRGNAM) $(OBJS) $(LDFLAGS)
+
+$(OBJS): $(SRCS)