summaryrefslogtreecommitdiffstats
path: root/games/oolite/oolite.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/oolite/oolite.SlackBuild')
-rw-r--r--games/oolite/oolite.SlackBuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/games/oolite/oolite.SlackBuild b/games/oolite/oolite.SlackBuild
index 04d0866d96..3734a5cf98 100644
--- a/games/oolite/oolite.SlackBuild
+++ b/games/oolite/oolite.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for oolite
-# Copyright 2016 - 2020 Johannes Schoepfer, Germany
+# Copyright 2016 - 2022 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Modified by the SlackBuilds.org project.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=oolite
VERSION=${VERSION:-1.90}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +40,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -59,9 +68,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf oolite-source-$VERSION
-tar vxf $CWD/oolite-source-$VERSION.tar.bz2
-cd oolite-source-$VERSION
+rm -rf $PRGNAM-source-$VERSION
+tar vxf $CWD/$PRGNAM-source-$VERSION.tar.bz2
+cd $PRGNAM-source-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -69,17 +78,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Make sure only system libs may be used
+# Make sure only system libs will be used
rm deps/Linux-deps/x86*/lib/*
+rm -rf deps/Linux-deps/include/*
source /usr/share/GNUstep/Makefiles/GNUstep.sh
export GNUSTEP_MAKEFILES=/usr/share/GNUstep/Makefiles
-## Link to espeak-ng instead of espeak
-# -e "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" \
sed -i \
- -e "/ADDITIONAL_OBJCFLAGS/s/=/= -fobjc-exceptions ${SLKCFLAGS}/" \
+ -e "/ADDITIONAL_OBJCFLAGS/s/=/= ${SLKCFLAGS}/" \
-e "s/-mtune=generic//g" \
- -e "s/ -lpng / -l:libpng14.so.14 /g" \
+ -e "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" \
GNUmakefile
make -f Makefile ESPEAK=yes use_deps=no debug=no release
@@ -119,4 +127,4 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE