summaryrefslogtreecommitdiffstats
path: root/games/sdlpop
diff options
context:
space:
mode:
Diffstat (limited to 'games/sdlpop')
-rw-r--r--games/sdlpop/README7
-rw-r--r--games/sdlpop/doinst.sh6
-rw-r--r--games/sdlpop/sdlpop.SlackBuild44
-rw-r--r--games/sdlpop/sdlpop.desktop2
-rw-r--r--games/sdlpop/sdlpop.info10
-rw-r--r--games/sdlpop/sdlpop.pngbin42664 -> 108739 bytes
-rw-r--r--games/sdlpop/slack-desc2
7 files changed, 47 insertions, 24 deletions
diff --git a/games/sdlpop/README b/games/sdlpop/README
index 96a4ef218c..02056b099f 100644
--- a/games/sdlpop/README
+++ b/games/sdlpop/README
@@ -1,5 +1,6 @@
sdlpop (Prince of Persia rewrite)
-SDLPoP is an open-source port of Prince of Persia 1, that runs natively
-under Windows and Linux. It is based on the DOS version of the game,
-and uses SDL 2. All data files needed to play the game are included.
+SDLPoP is an open-source port of Prince of Persia 1, that runs
+natively under Windows and Linux. It is based on the MS-DOS version
+of the game, and uses SDL 2. All data files needed to play the game
+are included.
diff --git a/games/sdlpop/doinst.sh b/games/sdlpop/doinst.sh
index 5fb28930db..3e5691a052 100644
--- a/games/sdlpop/doinst.sh
+++ b/games/sdlpop/doinst.sh
@@ -1,3 +1,9 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/games/sdlpop/sdlpop.SlackBuild b/games/sdlpop/sdlpop.SlackBuild
index 0ab701bf92..45e6ecc8ef 100644
--- a/games/sdlpop/sdlpop.SlackBuild
+++ b/games/sdlpop/sdlpop.SlackBuild
@@ -1,13 +1,18 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for sdlpop
-# Written by B. Watson (yalhcru@gmail.com)
+# Written by B. Watson (urchlay@slackware.uk)
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-# 20180611 bkw: updated for v1.18.1.
-
+# 20230712 bkw: updated for v1.23.
+# 20211025 bkw:
+# - updated for v1.22.
+# - new icon, new-style icons.
+# 20200927 bkw: updated for v1.21.
+# 20191127 bkw: updated for v1.20.
+# 20180611 bkw: updated for v1.20.
# 20170316 bkw:
# - updated for v1.17.
# - use github for download (saves bandwidth, the homepage's zip file has
@@ -16,10 +21,13 @@
# - update man page (new 1.17 options).
# - update wrapper script to support both system-wide and per-user mods.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=sdlpop
-VERSION=${VERSION:-1.18.1}
+VERSION=${VERSION:-1.23}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -29,7 +37,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -59,11 +71,8 @@ rm -rf $ZIPNAME-$VERSION
unzip -a $CWD/$ZIPNAME-$VERSION.zip
cd $ZIPNAME-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
sed -i "/^CFLAGS/s,\$, $SLKCFLAGS," src/Makefile
make -C src
@@ -82,10 +91,17 @@ gzip -9c < $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz
mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
# icon downloaded from:
-# http://www.veryicon.com/icons/game/mega-games-pack-26/prince-persia-2008-2.html
+# https://www.veryicon.com/icons/game/mega-games-pack-26/prince-persia-2008-1.html
# 1.17 now has an icon.png, but it's 32x32 and not transparent, so I'll keep
# using the one I used for 1.16.
-cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+for px in 16 32 48 64 128; do
+ size=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$size/apps
+ mkdir -p $dir
+ convert -resize $size $CWD/$PRGNAM.png $dir/$PRGNAM.png
+done
+
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
# .desktop written for this build
cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
@@ -99,4 +115,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/games/sdlpop/sdlpop.desktop b/games/sdlpop/sdlpop.desktop
index a6e60fc602..0bff6d661d 100644
--- a/games/sdlpop/sdlpop.desktop
+++ b/games/sdlpop/sdlpop.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=sdlpop
Comment=Prince of Persia I
-Exec=sdlpop
+Exec=/usr/games/sdlpop
Icon=sdlpop
Terminal=false
Type=Application
diff --git a/games/sdlpop/sdlpop.info b/games/sdlpop/sdlpop.info
index e679160222..93b46958e5 100644
--- a/games/sdlpop/sdlpop.info
+++ b/games/sdlpop/sdlpop.info
@@ -1,10 +1,10 @@
PRGNAM="sdlpop"
-VERSION="1.18.1"
+VERSION="1.23"
HOMEPAGE="http://www.popot.org/get_the_games.php?game=SDLPoP"
-DOWNLOAD="https://github.com/NagyD/SDLPoP/archive/v1.18.1/SDLPoP-1.18.1.zip"
-MD5SUM="91216e72cf0d1b8e726bfe3fc7e33712"
+DOWNLOAD="https://github.com/NagyD/SDLPoP/archive/v1.23/SDLPoP-1.23.zip"
+MD5SUM="ca18e54fb55790b409555f5ccc347f64"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="SDL2_mixer SDL2_image"
+REQUIRES=""
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"
diff --git a/games/sdlpop/sdlpop.png b/games/sdlpop/sdlpop.png
index 1931752195..8861e76a0f 100644
--- a/games/sdlpop/sdlpop.png
+++ b/games/sdlpop/sdlpop.png
Binary files differ
diff --git a/games/sdlpop/slack-desc b/games/sdlpop/slack-desc
index 3a48629df3..df7d6f56d4 100644
--- a/games/sdlpop/slack-desc
+++ b/games/sdlpop/slack-desc
@@ -9,7 +9,7 @@
sdlpop: sdlpop (Prince of Persia rewrite)
sdlpop:
sdlpop: SDLPoP is an open-source port of Prince of Persia 1, that runs
-sdlpop: natively under Windows and Linux. It is based on the DOS version
+sdlpop: natively under Windows and Linux. It is based on the MS-DOS version
sdlpop: of the game, and uses SDL 2. All data files needed to play the game
sdlpop: are included.
sdlpop: