summaryrefslogtreecommitdiffstats
path: root/games/wesnoth/wesnoth.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'games/wesnoth/wesnoth.SlackBuild')
-rw-r--r--games/wesnoth/wesnoth.SlackBuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/games/wesnoth/wesnoth.SlackBuild b/games/wesnoth/wesnoth.SlackBuild
index e216827b35..f5acbe9dba 100644
--- a/games/wesnoth/wesnoth.SlackBuild
+++ b/games/wesnoth/wesnoth.SlackBuild
@@ -27,7 +27,7 @@
PRGNAM=wesnoth
VERSION=${VERSION:-1.10.6}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -88,6 +88,15 @@ find . \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
+# Fix build problem on future GCC 4.8.0
+sed -i 's/-Werror//' CMakeLists.txt
+
+# Fix segfault
+# Upstream bug report and patch
+# https://gna.org/bugs/index.php?20742
+# https://github.com/wesnoth/wesnoth-old/commit/bbd7f6.patch
+patch -p1 < $CWD/fix-segfault.patch
+
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \