summaryrefslogtreecommitdiffstats
path: root/graphics/implot
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/implot')
-rw-r--r--graphics/implot/CMakeLists.txt52
-rw-r--r--graphics/implot/README7
-rw-r--r--graphics/implot/implot.SlackBuild108
-rw-r--r--graphics/implot/implot.info10
-rw-r--r--graphics/implot/slack-desc19
5 files changed, 196 insertions, 0 deletions
diff --git a/graphics/implot/CMakeLists.txt b/graphics/implot/CMakeLists.txt
new file mode 100644
index 0000000000..6807c550d7
--- /dev/null
+++ b/graphics/implot/CMakeLists.txt
@@ -0,0 +1,52 @@
+cmake_minimum_required(VERSION 3.8)
+project(implot CXX)
+
+find_package(imgui CONFIG REQUIRED)
+get_target_property(IMGUI_INCLUDE_DIRS imgui::imgui
+ INTERFACE_INCLUDE_DIRECTORIES
+)
+
+set(CMAKE_DEBUG_POSTFIX d)
+
+add_library(${PROJECT_NAME} "")
+add_library(${PROJECT_NAME}::${PROJECT_NAME} ALIAS ${PROJECT_NAME})
+target_compile_features(${PROJECT_NAME} PUBLIC cxx_std_11)
+target_include_directories(
+ ${PROJECT_NAME}
+ PUBLIC
+ $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}>
+ $<INSTALL_INTERFACE:include>
+ PRIVATE
+ ${IMGUI_INCLUDE_DIRS}
+)
+
+target_sources(
+ ${PROJECT_NAME}
+ PRIVATE
+ ${CMAKE_CURRENT_SOURCE_DIR}/implot.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/implot_items.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/implot_demo.cpp
+)
+
+install(
+ TARGETS ${PROJECT_NAME}
+ EXPORT ${PROJECT_NAME}_target
+ ARCHIVE DESTINATION lib
+ LIBRARY DESTINATION lib
+ RUNTIME DESTINATION bin
+)
+
+if(NOT IMPLOT_SKIP_HEADERS)
+ install(FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/implot.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/implot_internal.h
+ DESTINATION include
+ )
+endif()
+
+install(
+ EXPORT ${PROJECT_NAME}_target
+ NAMESPACE ${PROJECT_NAME}::
+ FILE ${PROJECT_NAME}-config.cmake
+ DESTINATION share/${PROJECT_NAME}
+)
diff --git a/graphics/implot/README b/graphics/implot/README
new file mode 100644
index 0000000000..cb96f0c13a
--- /dev/null
+++ b/graphics/implot/README
@@ -0,0 +1,7 @@
+ImPlot is an immediate mode, GPU accelerated plotting library for Dear
+ImGui. It aims to provide a first-class API that ImGui fans will love.
+ImPlot is well suited for visualizing program data in real-time or
+creating interactive plots, and requires minimal code to integrate.
+Just like ImGui, it does not burden the end user with GUI state
+management, avoids STL containers and C++ headers, and has no external
+dependencies except for ImGui itself.
diff --git a/graphics/implot/implot.SlackBuild b/graphics/implot/implot.SlackBuild
new file mode 100644
index 0000000000..85838c4d93
--- /dev/null
+++ b/graphics/implot/implot.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/bash
+
+# Slackware build script for implot
+
+# Copyright 2022-2023 Steven Voges <Oregon, USA>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=implot
+VERSION=${VERSION:-0.16}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+cp $CWD/CMakeLists.txt .
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+if [ "$LIBDIRSUFFIX" != "" ]; then
+ mv $PKG/usr/lib $PKG/usr/lib${LIBDIRSUFFIX}
+ sed -i "s/\/lib\//\/lib${LIBDIRSUFFIX}\//g" $PKG/usr/share/$PRGNAM/$PRGNAM-config-release.cmake
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ *.md LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/implot/implot.info b/graphics/implot/implot.info
new file mode 100644
index 0000000000..a272c1ec4e
--- /dev/null
+++ b/graphics/implot/implot.info
@@ -0,0 +1,10 @@
+PRGNAM="implot"
+VERSION="0.16"
+HOMEPAGE="https://github.com/epezent/implot"
+DOWNLOAD="https://github.com/epezent/implot/archive/v0.16/implot-0.16.tar.gz"
+MD5SUM="56f81b59538a1d406dcb6788d0442b05"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="imgui"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/graphics/implot/slack-desc b/graphics/implot/slack-desc
new file mode 100644
index 0000000000..02d23a0885
--- /dev/null
+++ b/graphics/implot/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+implot: implot (Plotting Library)
+implot:
+implot: Immediate Mode Plotting
+implot:
+implot: Homepage: https://github.com/epezent/implot
+implot:
+implot:
+implot:
+implot:
+implot:
+implot: