summaryrefslogtreecommitdiffstats
path: root/graphics/qiv
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qiv')
-rw-r--r--graphics/qiv/README19
-rw-r--r--graphics/qiv/new_formats.diff46
-rw-r--r--graphics/qiv/qiv-allfmt.sqf5
-rw-r--r--graphics/qiv/qiv.SlackBuild31
-rw-r--r--graphics/qiv/qiv.info10
5 files changed, 58 insertions, 53 deletions
diff --git a/graphics/qiv/README b/graphics/qiv/README
index f8333c67bd..8daaa2239f 100644
--- a/graphics/qiv/README
+++ b/graphics/qiv/README
@@ -9,10 +9,7 @@ you can use qiv to set your X11-Desktop background.
These formats are supported by default:
-GIF TIFF XPM PNG PPM PNM PGM BMP JPEG SVG ICO TGA ICNS WMF[*]
-
-[*] If .wmf files won't load for you, make sure you've updated
- Slackware recently (e.g. "slackpkg upgrade-all").
+GIF TIFF XPM PNG PPM PNM PGM BMP JPEG SVG ICO TGA ICNS JP2
Optional supported formats:
@@ -22,16 +19,20 @@ PCX | pcx-pixbuf-loader
------------------------+-----------------------------------------------
PSD (PhotoShop native) | gdk-pixbuf-psd
------------------------+-----------------------------------------------
-WEBP | libwebp imlib2 webp-pixbuf-loader. Build and
- | install *in that order*.
-------------------------+-----------------------------------------------
-XCF (Gimp native) | xcf-pixbuf-loader
-------------------------+-----------------------------------------------
RAW (camera images, | libopenraw. Note that only a few raw image
various extensions) | formats will actually display with qiv. These
| include .crw (Canon), .erf (Epson), and
| .nef (Nikon).
------------------------+-----------------------------------------------
+WEBP | imlib2 and webp-pixbuf-loader. Build and
+ | install *in that order*.
+------------------------+-----------------------------------------------
+WMF (Windows MetaFile) | libwmf-type1-fonts (only needed for .wmf files
+ | with embedded text, but all the ones I tested
+ | do have text...)
+------------------------+-----------------------------------------------
+XCF (Gimp native) | xcf-pixbuf-loader
+------------------------+-----------------------------------------------
These are runtime dependencies, so they can be installed at any time
without rebuilding qiv.
diff --git a/graphics/qiv/new_formats.diff b/graphics/qiv/new_formats.diff
index bc5622fd89..0953a23b67 100644
--- a/graphics/qiv/new_formats.diff
+++ b/graphics/qiv/new_formats.diff
@@ -1,25 +1,22 @@
-diff -Naur qiv-2.3.2/Makefile qiv-2.3.2.patched/Makefile
---- qiv-2.3.2/Makefile 2017-11-03 14:27:27.000000000 -0400
-+++ qiv-2.3.2.patched/Makefile 2019-12-31 14:06:51.304388148 -0500
-@@ -24,7 +24,7 @@
- # skipped.) It should reflect whatever is compiled into imlib.
+diff -Naur qiv-2.3.3/Makefile qiv-2.3.3.patched/Makefile
+--- qiv-2.3.3/Makefile 2023-01-28 16:37:29.000000000 -0500
++++ qiv-2.3.3.patched/Makefile 2023-06-06 02:52:08.518230436 -0400
+@@ -26,7 +26,7 @@
+ # or is compiled into imlib.
# The latest version of imlib has removed imagemagick fallback support,
# so some extensions (XBM TGA) have been removed.
--EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO
-+EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP XCF PSD ICNS TGA RAW
+-EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP HEIF
++EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP HEIF XCF PSD ICNS TGA RAW JP2
# Comment this line out if your system doesn't have getopt_long().
GETOPT_LONG = -DHAVE_GETOPT_LONG
-diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
---- qiv-2.3.2/main.h 2017-11-03 14:27:27.000000000 -0400
-+++ qiv-2.3.2.patched/main.h 2019-12-31 14:27:29.455909124 -0500
-@@ -199,6 +199,27 @@
- #ifdef EXTN_SVG
- ".svg",
+diff -Naur qiv-2.3.3/main.h qiv-2.3.3.patched/main.h
+--- qiv-2.3.3/main.h 2023-01-28 16:37:29.000000000 -0500
++++ qiv-2.3.3.patched/main.h 2023-06-06 02:58:13.422196095 -0400
+@@ -211,6 +211,21 @@
+ #ifdef EXTN_HEIF
+ ".heic", ".heif",
#endif
-+#ifdef EXTN_WEBP
-+ ".webp",
-+#endif
+#ifdef EXTN_XCF
+ ".xcf",
+#endif
@@ -29,25 +26,19 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
+#ifdef EXTN_ICNS
+ ".icns",
+#endif
-+ /* BROKEN in slackware 14.2, using newer versions
-+ of jasper and gdk-pixbuf2 built with jasper didn't help.
-+ Disabled in Makefile. */
+#ifdef EXTN_JP2
+ ".jp2", ".jpc", ".jpx", ".j2k", ".jpf",
+#endif
+#ifdef EXTN_RAW
-+ "dng", "cr2", "crw", "nef", "orf", "pef", "arw", "erf", "mrw", "raf",
++ ".dng", ".cr2", ".crw", ".nef", ".orf", ".pef", ".arw", ".erf", ".mrw", ".raf",
+#endif
NULL
};
-@@ -238,6 +259,29 @@
- #ifdef EXTN_ICO
- "MS Windows icon resource",
+@@ -256,6 +271,27 @@
+ #ifdef EXTN_HEIF
+ "ISO Media, HEIF Image",
#endif
-+#ifdef EXTN_WEBP
-+ "RIFF (little-endian) data, Web/P image",
-+#endif
+#ifdef EXTN_XCF
+ "GIMP XCF image data",
+#endif
@@ -62,7 +53,8 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
+#endif
+#ifdef EXTN_RAW
+ /* 20191231 bkw: some of these (dng, nef, erf, pef) show up as TIFF
-+ with the file command, so we can't include them here. */
++ with the file command, so we can't include them here. cr3 is "ISO Media",
++ which fails to work if added here. */
+ "Canon CIFF",
+ "Canon CR2",
+ "Olympus ORF",
diff --git a/graphics/qiv/qiv-allfmt.sqf b/graphics/qiv/qiv-allfmt.sqf
index 5fa2cb06f6..a550ba4e91 100644
--- a/graphics/qiv/qiv-allfmt.sqf
+++ b/graphics/qiv/qiv-allfmt.sqf
@@ -1,7 +1,8 @@
+imlib2
libopenraw
-libwebp
webp-pixbuf-loader
xcf-pixbuf-loader
gdk-pixbuf-psd
pcx-pixbuf-loader
-imlib2
+libwmf-type1-fonts
+qiv
diff --git a/graphics/qiv/qiv.SlackBuild b/graphics/qiv/qiv.SlackBuild
index 0320a81708..cb552ebf14 100644
--- a/graphics/qiv/qiv.SlackBuild
+++ b/graphics/qiv/qiv.SlackBuild
@@ -1,13 +1,21 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for qiv
# Written by Pablo Santamaria (email removed)
-# Modified & now maintained by B. Watson <yalhcru@gmail.com>. Original
+# Modified & now maintained by B. Watson <urchlay@slackware.uk>. Original
# version had no license, modified version released under the WTFPL. See
# http://www.wtfpl.net/txt/copying/ for details.
+# 20230605 bkw:
+# - Update for v2.3.3.
+# - JPEG 2000 works now, so enable it in the Makefile.
+# - WMF is broken. Fixed by adding new libwmf-type1-fonts optional
+# dep. Documented in README.
+# - Rework new_formats.diff. Script can no longer build old version.
+# - Fix and update qiv-allfmt.sqf.
+
# 20191231 bkw:
# - Add libopenraw (raw camera image) formats, BUILD=2.
# - Remove mention of wmf-pixbuf loader from README and .sqf
@@ -29,10 +37,13 @@
# of man pages (upstream's 'make install' already does it)
# - Don't install README.INSTALL
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=qiv
-VERSION=${VERSION:-2.3.2}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.3.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -42,23 +53,23 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -e
@@ -113,4 +124,4 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/qiv/qiv.info b/graphics/qiv/qiv.info
index 1ec4d757ca..4061bbd4d7 100644
--- a/graphics/qiv/qiv.info
+++ b/graphics/qiv/qiv.info
@@ -1,10 +1,10 @@
PRGNAM="qiv"
-VERSION="2.3.2"
-HOMEPAGE="http://spiegl.de/qiv/"
-DOWNLOAD="http://spiegl.de/qiv/download/qiv-2.3.2.tgz"
-MD5SUM="e64dd2cbd49f31264f60012e0138549b"
+VERSION="2.3.3"
+HOMEPAGE="https://spiegl.de/qiv/"
+DOWNLOAD="https://spiegl.de/qiv/download/qiv-2.3.3.tgz"
+MD5SUM="62f7a3adf62b85cdc6244913abf56bac"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="imlib2"
MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
+EMAIL="urchlay@slackware.uk"