summaryrefslogtreecommitdiffstats
path: root/libraries/LucenePlusPlus
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/LucenePlusPlus')
-rw-r--r--libraries/LucenePlusPlus/76dc90f2b65d81be018c499714ff11e121ba5585.patch64
-rw-r--r--libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild26
-rw-r--r--libraries/LucenePlusPlus/LucenePlusPlus.info8
-rw-r--r--libraries/LucenePlusPlus/a460863810b3a6a473780686e5d3fd70bf4378ba.patch22
4 files changed, 106 insertions, 14 deletions
diff --git a/libraries/LucenePlusPlus/76dc90f2b65d81be018c499714ff11e121ba5585.patch b/libraries/LucenePlusPlus/76dc90f2b65d81be018c499714ff11e121ba5585.patch
new file mode 100644
index 0000000000..05babf97a0
--- /dev/null
+++ b/libraries/LucenePlusPlus/76dc90f2b65d81be018c499714ff11e121ba5585.patch
@@ -0,0 +1,64 @@
+From c18ead2b0c4aa62af01450cb12353a0baa51411f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bernhard=20Rosenkr=C3=A4nzer?= <bero@lindev.ch>
+Date: Wed, 27 Mar 2024 12:00:18 +0100
+Subject: [PATCH] Fix build with boost 1.85.0
+
+boost::filesystem::wpath has been deprecated (and typedef-ed to
+boost::filesystem::path) for a long time; it is removed from boost
+starting with 1.85.0-beta1.
+
+Use boost::filesystem::path instead.
+
+boost/filesystem/convenience.hpp has been removed (and was being
+included without being used anyway - its only use was indirectly
+pulling in boost/filesystem/directory.hpp, which is actually used).
+
+Include boost/filesystem/directory.hpp directly instead.
+---
+ src/core/store/MMapDirectory.cpp | 2 +-
+ src/core/util/FileUtils.cpp | 6 +++---
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/core/store/MMapDirectory.cpp b/src/core/store/MMapDirectory.cpp
+index beac7828..46156e3a 100644
+--- a/src/core/store/MMapDirectory.cpp
++++ b/src/core/store/MMapDirectory.cpp
+@@ -36,7 +36,7 @@ MMapIndexInput::MMapIndexInput(const String& path) {
+ bufferPosition = 0;
+ if (!path.empty()) {
+ try {
+- file.open(boost::filesystem::wpath(path), _length);
++ file.open(boost::filesystem::path(path), _length);
+ } catch (...) {
+ boost::throw_exception(FileNotFoundException(path));
+ }
+diff --git a/src/core/util/FileUtils.cpp b/src/core/util/FileUtils.cpp
+index 51508b57..d92efbb8 100644
+--- a/src/core/util/FileUtils.cpp
++++ b/src/core/util/FileUtils.cpp
+@@ -5,9 +5,9 @@
+ /////////////////////////////////////////////////////////////////////////////
+
+ #include "LuceneInc.h"
+-#include <boost/filesystem/convenience.hpp>
+ #include <boost/filesystem/operations.hpp>
+ #include <boost/filesystem/path.hpp>
++#include <boost/filesystem/directory.hpp>
+ #include "LuceneThread.h"
+ #include "StringUtils.h"
+ #include "FileUtils.h"
+@@ -128,12 +128,12 @@ String joinPath(const String& path, const String& file) {
+ }
+
+ String extractPath(const String& path) {
+- boost::filesystem::wpath parentPath(path.c_str());
++ boost::filesystem::path parentPath(path.c_str());
+ return parentPath.parent_path().wstring().c_str();
+ }
+
+ String extractFile(const String& path) {
+- boost::filesystem::wpath fileName(path.c_str());
++ boost::filesystem::path fileName(path.c_str());
+ return fileName.filename().wstring().c_str();
+ }
+
diff --git a/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild b/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild
index adc205acf4..338cd26ea9 100644
--- a/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild
+++ b/libraries/LucenePlusPlus/LucenePlusPlus.SlackBuild
@@ -1,8 +1,8 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for LucenePlusPlus
-# Copyright 2014-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2014-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,10 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=LucenePlusPlus
-VERSION=${VERSION:-3.0.7}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.0.9}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +38,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,10 +76,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Disable building internal gtest
-sed -i "s/include(CMakeExternal.txt)/#include(CMakeExternal.txt)/" CMakeLists.txt
-sed -i "s/enable_testing()/#enable_testing()/" CMakeLists.txt
-
+patch -p1 < $CWD/a460863810b3a6a473780686e5d3fd70bf4378ba.patch
+patch -p1 < $CWD/76dc90f2b65d81be018c499714ff11e121ba5585.patch
mkdir -p build
cd build
cmake \
@@ -81,6 +86,7 @@ cd build
-DCMAKE_INSTALL_PREFIX=/usr \
-DLIB_DESTINATION=/usr/lib${LIBDIRSUFFIX} \
-DCMAKE_CXX_FLAGS='-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT' \
+ -DENABLE_TEST=OFF \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
@@ -97,4 +103,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/LucenePlusPlus/LucenePlusPlus.info b/libraries/LucenePlusPlus/LucenePlusPlus.info
index 0d48b7d561..b9da9031e4 100644
--- a/libraries/LucenePlusPlus/LucenePlusPlus.info
+++ b/libraries/LucenePlusPlus/LucenePlusPlus.info
@@ -1,10 +1,10 @@
PRGNAM="LucenePlusPlus"
-VERSION="3.0.7"
+VERSION="3.0.9"
HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
-DOWNLOAD="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.7.tar.gz"
-MD5SUM="e260c1ff9c10af7070faee29f325f955"
+DOWNLOAD="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_3.0.9/LucenePlusPlus-rel_3.0.9.tar.gz"
+MD5SUM="33da6751de47523e22e7a1beebd78c29"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="gtest"
+REQUIRES=""
MAINTAINER="Willy Sudiarto Raharjo"
EMAIL="willysr@slackbuilds.org"
diff --git a/libraries/LucenePlusPlus/a460863810b3a6a473780686e5d3fd70bf4378ba.patch b/libraries/LucenePlusPlus/a460863810b3a6a473780686e5d3fd70bf4378ba.patch
new file mode 100644
index 0000000000..1c9d5681e4
--- /dev/null
+++ b/libraries/LucenePlusPlus/a460863810b3a6a473780686e5d3fd70bf4378ba.patch
@@ -0,0 +1,22 @@
+From f40f59c6e169b4e16b7a6439ecb26a629c6540d1 Mon Sep 17 00:00:00 2001
+From: Sergey Fedorov <vital.had@gmail.com>
+Date: Thu, 14 Mar 2024 20:37:34 +0800
+Subject: [PATCH] Fix install path for liblucene++.pc
+
+---
+ src/config/core/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/config/core/CMakeLists.txt b/src/config/core/CMakeLists.txt
+index e5691f54..69cfefcc 100644
+--- a/src/config/core/CMakeLists.txt
++++ b/src/config/core/CMakeLists.txt
+@@ -9,7 +9,7 @@ if(NOT WIN32)
+ install(
+ FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/liblucene++.pc"
+- DESTINATION "${LIB_DESTINATION}/pkgconfig")
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
+
+