summaryrefslogtreecommitdiffstats
path: root/libraries/OpenSceneGraph
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/OpenSceneGraph')
-rw-r--r--libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild40
-rw-r--r--libraries/OpenSceneGraph/OpenSceneGraph.info6
-rw-r--r--libraries/OpenSceneGraph/README20
-rw-r--r--libraries/OpenSceneGraph/no-asio-occ.diff20
4 files changed, 62 insertions, 24 deletions
diff --git a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
index a158f30565..bcf21cc5d8 100644
--- a/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
+++ b/libraries/OpenSceneGraph/OpenSceneGraph.SlackBuild
@@ -1,15 +1,18 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for OpenSceneGraph
# Written by Aleksandar Samardzic <asamardzic@gmail.com>
# Maintained by Jordan Evans <jordanevans19@gmail.com>
-# Maintained 2018 by Christoph Willing <chris.willing@linux.com>
+# Maintained 2018-2023 by Christoph Willing <chris.willing@linux.com>
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=OpenSceneGraph
-VERSION=${VERSION:-3.5.5}
+VERSION=${VERSION:-3.6.5}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -19,7 +22,14 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -38,12 +48,6 @@ else
LIBDIRSUFFIX=""
fi
-# Support OpenCASCADE, if installed
-occ=""
-# Not supported until version 3.5.6
-#ls -l /var/log/packages/OpenCASCADE* 2>/dev/null 1>/dev/null
-#[ $? -eq 0 ] && occ="-DOPENCASCADE_INCLUDE_DIR=/opt/OpenCASCADE/inc -DOPENCASCADE_LIBRARY_TYPE=Shared"
-
set -e
rm -rf $PKG
@@ -55,9 +59,13 @@ cd $PRGNAM-$PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+# If installed, ignore asio & OpenCASCADE
+# whose current versions at SBo cause build failure
+patch -p0 < $CWD/no-asio-occ.diff
mkdir -p build
cd build
@@ -65,12 +73,16 @@ cd build
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_POSTFIX=$LIBDIRSUFFIX \
-DCMAKE_BUILD_TYPE=Release \
- $occ \
-DBUILD_OSG_EXAMPLES=ON \
make
make install DESTDIR=$PKG
+
+ # No binaries in /usr/share. Move examples to /usr/bin
+ mv $PKG/usr/share/OpenSceneGraph/bin/* $PKG/usr/bin/
+ rm -rf $PKG/usr/share
cd ..
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -84,4 +96,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/OpenSceneGraph/OpenSceneGraph.info b/libraries/OpenSceneGraph/OpenSceneGraph.info
index 967fe46428..82925e0f04 100644
--- a/libraries/OpenSceneGraph/OpenSceneGraph.info
+++ b/libraries/OpenSceneGraph/OpenSceneGraph.info
@@ -1,8 +1,8 @@
PRGNAM="OpenSceneGraph"
-VERSION="3.5.5"
+VERSION="3.6.5"
HOMEPAGE="http://www.openscenegraph.org/"
-DOWNLOAD="https://github.com/openscenegraph/OpenSceneGraph/archive/OpenSceneGraph-3.5.5/OpenSceneGraph-OpenSceneGraph-3.5.5.tar.gz"
-MD5SUM="af7b1719c656192e69694cb12fcc4106"
+DOWNLOAD="https://github.com/openscenegraph/OpenSceneGraph/archive/OpenSceneGraph-3.6.5/OpenSceneGraph-OpenSceneGraph-3.6.5.tar.gz"
+MD5SUM="51b1c6ee5627246e78b23adbf0aa48f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/OpenSceneGraph/README b/libraries/OpenSceneGraph/README
index ec08826b7b..3741e35868 100644
--- a/libraries/OpenSceneGraph/README
+++ b/libraries/OpenSceneGraph/README
@@ -1,6 +1,6 @@
The OpenSceneGraph is an open source cross platform graphics toolkit
-for the development of high performance graphics applications such as
-flight simulators, games, virtual reality and scientific
+for the development of high performance graphics applications
+such as flight simulators, games, virtual reality and scientific
visualization. Based around the concept of a scene graph, it provides
an object oriented framework on top of OpenGL freeing the developer
from implementing and optimizing low level graphics calls, and
@@ -8,8 +8,14 @@ provides many additional utilities for rapid development of graphics
applications.
Plugins will be automatically generated using the following optional
-packages if they are detected at build time:
- dcmtk, ffmpeg, gdal, gtkglext, libgta, libLAS, nvidia-texture-tools,
- fltk, SDL2, wxGTK3
-These plugins offer significant additional functionality and are recommended
-for building a fully featured OpenSceneGraph.
+SBo packages if they are detected at build time:
+
+ collada-dom, dcmtk, fltk, fox-toolkit, gdal, gtkglext, libgta,
+ libLAS, nvidia-texture-tools, wxGTK3
+
+These plugins offer significant additional functionality and are
+recommended for building a fully featured OpenSceneGraph. However,
+note that you may not want support for three distinct widget toolkits
+(fltk, fox-toolkit, wxGTK3) in addition to the default GTK & SDL2
+viewers.
+
diff --git a/libraries/OpenSceneGraph/no-asio-occ.diff b/libraries/OpenSceneGraph/no-asio-occ.diff
new file mode 100644
index 0000000000..7f27a4b3f6
--- /dev/null
+++ b/libraries/OpenSceneGraph/no-asio-occ.diff
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2020-01-31 21:03:07.000000000 +1000
++++ CMakeLists.txt 2023-06-02 12:11:26.082000000 +1000
+@@ -743,7 +743,6 @@
+ FIND_PACKAGE(Inventor)
+ FIND_PACKAGE(Jasper)
+ FIND_PACKAGE(OpenEXR)
+- FIND_PACKAGE(OpenCascade)
+ FIND_PACKAGE(COLLADA)
+ FIND_PACKAGE(FBX)
+ FIND_PACKAGE(ZLIB)
+@@ -763,9 +762,6 @@
+ FIND_PACKAGE(GtkGl)
+ FIND_PACKAGE(DirectInput)
+ FIND_PACKAGE(NVTT)
+- IF (NOT WIN32)
+- FIND_PACKAGE(Asio)
+- ENDIF()
+ FIND_PACKAGE(ZeroConf)
+
+ FIND_PACKAGE(LIBLAS)