summaryrefslogtreecommitdiffstats
path: root/libraries/PyOpenGL/PyOpenGL.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/PyOpenGL/PyOpenGL.SlackBuild')
-rw-r--r--libraries/PyOpenGL/PyOpenGL.SlackBuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/libraries/PyOpenGL/PyOpenGL.SlackBuild b/libraries/PyOpenGL/PyOpenGL.SlackBuild
index 8d7711cf00..9bcec6a582 100644
--- a/libraries/PyOpenGL/PyOpenGL.SlackBuild
+++ b/libraries/PyOpenGL/PyOpenGL.SlackBuild
@@ -3,25 +3,25 @@
# Slackware build script for PyOpenGL
# Written by Evandro Alves Rodrigues
+# 20220304 bkw: Modified by SlackBuilds.org: update for v3.1.6,
+# add python3 support.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=PyOpenGL
-VERSION=${VERSION:-3.0.1}
+VERSION=${VERSION:-3.1.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -48,18 +48,19 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- ChangeLog.txt PKG-INFO license.txt \
+ readme.rst PKG-INFO license.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild