summaryrefslogtreecommitdiffstats
path: root/libraries/QDarkStyle/QDarkStyle.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/QDarkStyle/QDarkStyle.SlackBuild')
-rw-r--r--libraries/QDarkStyle/QDarkStyle.SlackBuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/libraries/QDarkStyle/QDarkStyle.SlackBuild b/libraries/QDarkStyle/QDarkStyle.SlackBuild
index f172e97a72..8bcc003771 100644
--- a/libraries/QDarkStyle/QDarkStyle.SlackBuild
+++ b/libraries/QDarkStyle/QDarkStyle.SlackBuild
@@ -2,7 +2,9 @@
# Slackware build script for QDarkStyle
-# Copyright 2014-2020 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2020 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2022-2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 nomnombtc <nomnombtc@arcor.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +27,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=QDarkStyle
-VERSION=${VERSION:-1.11}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-3.2.3}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -59,6 +58,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -79,18 +81,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS.rst CHANGES.rst CODE_OF_CONDUCT.rst CONTRIBUTING.rst LICENSE.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install