summaryrefslogtreecommitdiffstats
path: root/libraries/cpp-jwt
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/cpp-jwt')
-rw-r--r--libraries/cpp-jwt/README8
-rw-r--r--libraries/cpp-jwt/cpp-jwt.SlackBuild110
-rw-r--r--libraries/cpp-jwt/cpp-jwt.info10
-rw-r--r--libraries/cpp-jwt/slack-desc19
4 files changed, 147 insertions, 0 deletions
diff --git a/libraries/cpp-jwt/README b/libraries/cpp-jwt/README
new file mode 100644
index 0000000000..080ceaef3d
--- /dev/null
+++ b/libraries/cpp-jwt/README
@@ -0,0 +1,8 @@
+JSON Web Token library for C++
+
+For the uninitiated, JSON Web Token(JWT) is a JSON based standard
+(RFC-7519) for creating assertions or access tokens that consists of
+some claims (encoded within the assertion). This assertion can be used
+in some kind of bearer authentication mechanism that the server will
+provide to clients, and the clients can make use of the provided
+assertion for accessing resources.
diff --git a/libraries/cpp-jwt/cpp-jwt.SlackBuild b/libraries/cpp-jwt/cpp-jwt.SlackBuild
new file mode 100644
index 0000000000..e2244cce45
--- /dev/null
+++ b/libraries/cpp-jwt/cpp-jwt.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/bash
+
+# Slackware build script for cpp-jwt
+
+# Copyright 2022-2023 Steven Voges <Oregon, USA>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=cpp-jwt
+VERSION=${VERSION:-1.4}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+#Fix version so cmake can fine the proper files.
+sed -i "s/1.2.0/1.4.0/g" CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCPP_JWT_BUILD_EXAMPLES=OFF \
+ -DCPP_JWT_BUILD_TESTS=OFF \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+rmdir $PKG/usr/include/jwt/test
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/cpp-jwt/cpp-jwt.info b/libraries/cpp-jwt/cpp-jwt.info
new file mode 100644
index 0000000000..d83fe70a7e
--- /dev/null
+++ b/libraries/cpp-jwt/cpp-jwt.info
@@ -0,0 +1,10 @@
+PRGNAM="cpp-jwt"
+VERSION="1.4"
+HOMEPAGE="https://github.com/arun11299/cpp-jwt"
+DOWNLOAD="https://github.com/arun11299/cpp-jwt/archive/v1.4/cpp-jwt-1.4.tar.gz"
+MD5SUM="9464d20c2e0c316a0adf6e035f7bfaf5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="nlohmann_json"
+MAINTAINER="Steven Voges"
+EMAIL="svoges.sbo@gmail.com"
diff --git a/libraries/cpp-jwt/slack-desc b/libraries/cpp-jwt/slack-desc
new file mode 100644
index 0000000000..afd021655c
--- /dev/null
+++ b/libraries/cpp-jwt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cpp-jwt: cpp-jwt (JWT for C++)
+cpp-jwt:
+cpp-jwt: JSON Web Token library for C++
+cpp-jwt:
+cpp-jwt: Homepage: https://github.com/arun11299/cpp-jwt
+cpp-jwt:
+cpp-jwt:
+cpp-jwt:
+cpp-jwt:
+cpp-jwt:
+cpp-jwt: