summaryrefslogtreecommitdiffstats
path: root/libraries/ftgl
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/ftgl')
-rw-r--r--libraries/ftgl/README21
-rw-r--r--libraries/ftgl/ftgl.SlackBuild94
-rw-r--r--libraries/ftgl/ftgl.info12
-rw-r--r--libraries/ftgl/patches/gcc47.patch12
-rw-r--r--libraries/ftgl/patches/nopdfdocs.patch23
-rw-r--r--libraries/ftgl/patches/spam.patch16
6 files changed, 66 insertions, 112 deletions
diff --git a/libraries/ftgl/README b/libraries/ftgl/README
index 38ead6cc5e..f7b12ee5ea 100644
--- a/libraries/ftgl/README
+++ b/libraries/ftgl/README
@@ -1,10 +1,15 @@
-FTGL is a font rendering library for OpenGL applications.
+ftgl (font rendering library for OpenGL applications)
FTGL is a free, open source library to enable developers to use
-arbitrary fonts in their OpenGL (www.opengl.org) applications.
-Unlike other OpenGL font libraries FTGL uses standard font file
-formats so doesn't need a preprocessing step to convert the high
-quality font data into a lesser quality, proprietary format.
-FTGL uses the Freetype (www.freetype.org) font library to open and
-'decode' the fonts. It then takes that output and stores it in a
-format most efficient for OpenGL rendering.
+arbitrary fonts in their OpenGL (www.opengl.org) applications. Unlike
+other OpenGL font libraries FTGL uses standard font file formats so
+doesn't need a preprocessing step to convert the high quality font
+data into a lesser quality, proprietary format. FTGL uses the Freetype
+(www.freetype.org) font library to open and 'decode' the fonts. It
+then takes that output and stores it in a format most efficient for
+OpenGL rendering.
+
+By default, the HTML and PDF API documentation for ftgl is not
+included in the package. If you want to build the docs, export
+DOCS=yes in the script's environment. You only need this if you're
+developing software that uses ftgl.
diff --git a/libraries/ftgl/ftgl.SlackBuild b/libraries/ftgl/ftgl.SlackBuild
index 42294ead0f..deb648f898 100644
--- a/libraries/ftgl/ftgl.SlackBuild
+++ b/libraries/ftgl/ftgl.SlackBuild
@@ -1,31 +1,26 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for ftgl
-#
-# Copyright 2007 Niklas "Nille" Åkerström
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Originally written by Niklas "Nille" Åkerström, formerly maintained
+# by Johannes Schoepfer.
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20220207 bkw: BUILD=2.
+# - take over maintenance.
+# - relicense as WTFPL with permission.
+# - add option to build the docs, now that we have texlive.
+# - do not install useless INSTALL in doc dir.
+# - remove .la file.
+
+cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ftgl
-VERSION=${VERSION:-2.1.3_rc5}
-BUILD=${BUILD:-4}
+VERSION=${VERSION:-2.4.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +30,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -60,44 +59,45 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$(echo $VERSION | tr _ \~)
-tar xvf $CWD/$PRGNAM-$(echo $VERSION | tr _ -).tar.bz2
-cd $PRGNAM-$(echo $VERSION | tr _ \~)
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Fix building with gcc-4.7.x
-patch -p1 < $CWD/patches/gcc47.patch
-# Fix spam that breaks build after autoreconfing
-patch -p1 < $CWD/patches/spam.patch
-# Avoid building pdf docs (seems broken ATM)
-patch -p0 < $CWD/patches/nopdfdocs.patch
-autoreconf -i
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+./autogen.sh
+
+# docs require texlive, tetex is not sufficient. we have texlive in
+# 15.0, so we can build the docs, but don't by default (most users
+# won't need them).
+DOCOPT="--disable-doc"
+[ "${DOCS:-no}" = "yes" ] && DOCOPT="--enable-doc"
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -std=gnu++11" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc
+ --disable-static \
+ $DOCOPT
make GLUT_LIBS="-lglut -lGLU -lGL -lm"
make install-strip DESTDIR=$PKG
+rm -f $PKG/usr/lib*/*.la
+
+cp src/FT{Face,Size}.h $PKG/usr/include/FTGL
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp AUTHORS BUGS COPYING ChangeLog NEWS README TODO $PKGDOC
+mv $PKG/usr/share/doc/$PRGNAM/* $PKGDOC
rm -rf $PKG/usr/share
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/ftgl/ftgl.info b/libraries/ftgl/ftgl.info
index 966cd73a0e..7073014c7f 100644
--- a/libraries/ftgl/ftgl.info
+++ b/libraries/ftgl/ftgl.info
@@ -1,10 +1,10 @@
PRGNAM="ftgl"
-VERSION="2.1.3_rc5"
-HOMEPAGE="https://sourceforge.net/projects/ftgl/"
-DOWNLOAD="http://downloads.sourceforge.net/ftgl/ftgl-2.1.3-rc5.tar.bz2"
-MD5SUM="c7879018cde844059495b3029b0b6503"
+VERSION="2.4.0"
+HOMEPAGE="https://github.com/frankheckenbach/ftgl"
+DOWNLOAD="https://github.com/frankheckenbach/ftgl/archive/v2.4.0/ftgl-2.4.0.tar.gz"
+MD5SUM="fba1e1c548ebe3ab362495e96a7a0670"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Niklas 'Nille' Åkerström"
-EMAIL="nille.kungen[AT]gmail.com"
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"
diff --git a/libraries/ftgl/patches/gcc47.patch b/libraries/ftgl/patches/gcc47.patch
deleted file mode 100644
index d8af850acf..0000000000
--- a/libraries/ftgl/patches/gcc47.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur ftgl-2.1.3~rc5.orig/test/Makefile.am ftgl-2.1.3~rc5/test/Makefile.am
---- ftgl-2.1.3~rc5.orig/test/Makefile.am 2008-06-02 03:10:10.000000000 +0200
-+++ ftgl-2.1.3~rc5/test/Makefile.am 2012-04-01 06:59:36.523040292 +0200
-@@ -52,7 +52,7 @@
-
- CXXTest_CXXFLAGS = $(FT2_CFLAGS) $(GL_CFLAGS)
- CXXTest_LDFLAGS = $(FT2_LIBS) $(GLUT_LIBS) -lcppunit
--CXXTest_LDADD = ../src/libftgl.la
-+CXXTest_LDADD = ../src/libftgl.la -lm
-
- CTest_SOURCES = \
- CTest.c \
diff --git a/libraries/ftgl/patches/nopdfdocs.patch b/libraries/ftgl/patches/nopdfdocs.patch
deleted file mode 100644
index e938665bad..0000000000
--- a/libraries/ftgl/patches/nopdfdocs.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- configure.ac.old 2008-11-21 14:41:15.000000000 +0100
-+++ configure.ac 2008-11-21 14:44:19.000000000 +0100
-@@ -64,19 +64,11 @@
- CFLAGS="${CFLAGS} -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs"
-
- # Build HTML documentatin?
--AC_PATH_PROG(DOXYGEN, doxygen, no)
-+DOXYGEN="no"
- AM_CONDITIONAL(HAVE_DOXYGEN, test "x$DOXYGEN" != "xno")
-
- # Build PDF documentation?
--AC_PATH_PROG(LATEX, pdflatex, no)
--AC_PATH_PROG(KPSEWHICH, kpsewhich, no)
--AC_PATH_PROG(DVIPS, dvips, no)
--AC_PATH_PROG(CONVERT, convert, no)
--AC_PATH_PROG(EPSTOPDF, epstopdf, no)
--if test "${DVIPS}" = "no" -o "${KPSEWHICH}" = "no" -o "${EPSTOPDF}" = "no" \
-- -o "${CONVERT}" = "no"; then
- LATEX="no"
--fi
- if test "x${LATEX}" != "xno"; then
- AC_MSG_CHECKING(for a4.sty and a4wide.sty)
- if "${KPSEWHICH}" a4.sty >/dev/null 2>&1; then
diff --git a/libraries/ftgl/patches/spam.patch b/libraries/ftgl/patches/spam.patch
deleted file mode 100644
index 7f3dbbd227..0000000000
--- a/libraries/ftgl/patches/spam.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -Naur ftgl-2.1.3~rc5.orig/Makefile.am ftgl-2.1.3~rc5/Makefile.am
---- ftgl-2.1.3~rc5.orig/Makefile.am 2008-05-12 20:04:08.000000000 +0200
-+++ ftgl-2.1.3~rc5/Makefile.am 2012-04-01 07:09:50.727996032 +0200
-@@ -26,12 +26,6 @@
-
- # Print out an informative summary.
- all-local:
-- @$(ECHO) "Done."
-- @$(ECHO)
-- @if test "x$(MAKECMDGOALS)" = "xall-am" -o "x$(.TARGETS)" = "xall-am" -o "x$(MAKECMDGOALS)" = "x" -o "x$(.TARGETS)" = "x" ; then \
-- $(ECHO) "---" ;\
-- $(ECHO) "Run 'make install' to begin installation into $(prefix)" ;\
-- fi
- @$(ECHO)
-
- # Upload documentation