summaryrefslogtreecommitdiffstats
path: root/libraries/lensfun
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/lensfun')
-rw-r--r--libraries/lensfun/README9
-rw-r--r--libraries/lensfun/lensfun-fix-python-install-dir.patch27
-rw-r--r--libraries/lensfun/lensfun.SlackBuild99
-rw-r--r--libraries/lensfun/lensfun.info10
-rw-r--r--libraries/lensfun/slack-desc19
5 files changed, 0 insertions, 164 deletions
diff --git a/libraries/lensfun/README b/libraries/lensfun/README
deleted file mode 100644
index f9ba83d9f5..0000000000
--- a/libraries/lensfun/README
+++ /dev/null
@@ -1,9 +0,0 @@
-lensfun is a library that provide a open source database of photographic
-lenses and their characteristics, also provides a set of algorithms for
-correcting images based on detailed knowledge of lens properties and
-calibration data.
-
-NOTE:
-There are 2 scripts that requires python3:
-- lensfun-add-adapter
-- lensfun-update-data
diff --git a/libraries/lensfun/lensfun-fix-python-install-dir.patch b/libraries/lensfun/lensfun-fix-python-install-dir.patch
deleted file mode 100644
index e6713f9bb6..0000000000
--- a/libraries/lensfun/lensfun-fix-python-install-dir.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 3b46bb2a4eada7f29e016d586229782f6d1c35bb Mon Sep 17 00:00:00 2001
-From: Pino Toscano <toscano.pino@tiscali.it>
-Date: Sat, 9 Jan 2016 11:47:37 +0100
-Subject: [PATCH] cmake: fix DESTDIR installation for python
-
-When running `setup.py install`, respect the value of the DESTDIR
-environment variable so staged installs (used by distros, for example)
-work.
----
- apps/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
-index 70c77fd..2f6f8f1 100644
---- a/apps/CMakeLists.txt
-+++ b/apps/CMakeLists.txt
-@@ -42,5 +42,5 @@ IF(PYTHON)
- IF(NOT DEFINED SETUP_PY_INSTALL_PREFIX)
- SET(SETUP_PY_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}")
- ENDIF()
-- INSTALL(CODE "execute_process(COMMAND ${PYTHON} ${SETUP_PY} install --prefix=${SETUP_PY_INSTALL_PREFIX})")
-+ INSTALL(CODE "execute_process(COMMAND ${PYTHON} ${SETUP_PY} install --prefix=\$ENV{DESTDIR}${SETUP_PY_INSTALL_PREFIX})")
- ENDIF(PYTHON)
---
-2.6.4
-
-
diff --git a/libraries/lensfun/lensfun.SlackBuild b/libraries/lensfun/lensfun.SlackBuild
deleted file mode 100644
index 6e9fc0a567..0000000000
--- a/libraries/lensfun/lensfun.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script of lensfun
-
-# Copyright 2009 Ricardson Williams <ricardsonwilliams at yahoo.com.br>
-# Copyright 2013-2016 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=lensfun
-VERSION=${VERSION:-0.3.2}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p1 < $CWD/lensfun-fix-python-install-dir.patch
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX=${LIBDIRSUFFIX} \
- -DBUILD_FOR_SSE=ON \
- -DBUILD_FOR_SSE2=ON \
- -DBUILD_TESTS=OFF \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* docs/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -c n -l y $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/lensfun/lensfun.info b/libraries/lensfun/lensfun.info
deleted file mode 100644
index 9f66e9188b..0000000000
--- a/libraries/lensfun/lensfun.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="lensfun"
-VERSION="0.3.2"
-HOMEPAGE="http://lensfun.sourceforge.net/"
-DOWNLOAD="http://sourceforge.net/projects/lensfun/files/0.3.2/lensfun-0.3.2.tar.gz"
-MD5SUM="247e59a0812ec451f6cd0d20b3379cb5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Willy Sudiarto Raharjo"
-EMAIL="willysr@slackbuilds.org"
diff --git a/libraries/lensfun/slack-desc b/libraries/lensfun/slack-desc
deleted file mode 100644
index 690364a276..0000000000
--- a/libraries/lensfun/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-lensfun: lensfun (photographic lens characteristics database library)
-lensfun:
-lensfun: lensfun is a library that provide a open source database of
-lensfun: photographic lenses and their characteristics also provides
-lensfun: a set of algorithms for correcting images based on detailed
-lensfun: knowledge of lens properties and calibration data.
-lensfun:
-lensfun: Homepage: http://lensfun.sourceforge.net/
-lensfun:
-lensfun:
-lensfun: