summaryrefslogtreecommitdiffstats
path: root/libraries/libaaio/libaaio.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libaaio/libaaio.SlackBuild')
-rw-r--r--libraries/libaaio/libaaio.SlackBuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/libraries/libaaio/libaaio.SlackBuild b/libraries/libaaio/libaaio.SlackBuild
index 88a0ab4909..3d28a72f22 100644
--- a/libraries/libaaio/libaaio.SlackBuild
+++ b/libraries/libaaio/libaaio.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh -e
-# SlackBuild for libaaio, 3 May 2016
-# Arthur W. Green <lynx@panix.com>
+# SlackBuild for libaaio, 5 January 2017
+# Arthur W. Green <awg@posteo.us>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -28,12 +28,12 @@
PRGNAM=libaaio
VERSION=${VERSION:-0.3.1}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -44,8 +44,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -67,16 +67,20 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . -exec chmod -R u+w,go-w,a+rX-st {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# twiddle and patch files to appease crusty autoconf.
+# patch files to appease some crusty autoconf.
mv -v configure.in configure.ac
patch -p1 < $CWD/$PRGNAM.patch
mkdir -p m4 # a stub.
autoreconf --install --force
-# build BOTH static and shared libraries, as software dependent
-# on libaaio expect libaaio.a more often than not.
+# we build BOTH static and shared libraries, as software dependent on
+# libaaio expect libaaio.a more often than not.
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \