summaryrefslogtreecommitdiffstats
path: root/libraries/libb64/libb64.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libb64/libb64.SlackBuild')
-rw-r--r--libraries/libb64/libb64.SlackBuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/libraries/libb64/libb64.SlackBuild b/libraries/libb64/libb64.SlackBuild
index 34f303a949..93923597d9 100644
--- a/libraries/libb64/libb64.SlackBuild
+++ b/libraries/libb64/libb64.SlackBuild
@@ -22,6 +22,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220209 bkw: Modified by SlackBuilds.org, to fix the build on 15.0.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libb64
@@ -32,15 +34,12 @@ PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,8 +49,10 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+# 20220209 bkw: src/Makefile has "CFLAGS += -O3" which overrides our
+# -O2. Not going to "fix" it.
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -84,7 +85,8 @@ sed -i 's|-Werror||' */Makefile
# Build shared library.
patch -p0 < $CWD/shared-library.patch
-CFLAGS="$SLKCFLAGS" make
+# 20220209 bkw: leave the -j1 here please, it's necessary.
+CFLAGS="$SLKCFLAGS" make -j1
# Manually install.
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}