summaryrefslogtreecommitdiffstats
path: root/libraries/libpgf/libpgf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libpgf/libpgf.SlackBuild')
-rw-r--r--libraries/libpgf/libpgf.SlackBuild35
1 files changed, 20 insertions, 15 deletions
diff --git a/libraries/libpgf/libpgf.SlackBuild b/libraries/libpgf/libpgf.SlackBuild
index 09d41001e1..47f5f3c297 100644
--- a/libraries/libpgf/libpgf.SlackBuild
+++ b/libraries/libpgf/libpgf.SlackBuild
@@ -20,11 +20,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220421 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - remove dos2unix dep.
+# - move API docs to correct Slackware doc dir (no more /usr/share/doc).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libpgf
VERSION=${VERSION:-7.21.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -36,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -73,14 +74,18 @@ cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
sed -i "s|7.15.32|$VERSION|g" configure.ac
touch README
-dos2unix *.{am,ac,in,sh} */*.{am,in}
+
+# 20220421 bkw: perl ships with Slackware, use it instead of dos2unix.
+perl -i -pe 's,\r,,' *.{am,ac,in,sh} */*.{am,in}
+
#sed -i -e "/HAS_DOXYGEN/{N;N;d}" Makefile.am
+
autoreconf -i
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -91,20 +96,20 @@ CFLAGS="$SLKCFLAGS" \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
+make install-strip DESTDIR=$PKG
+gzip -9 $PKG/usr/man/man*/*
rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+if [ -e $PKG/usr/share/doc/$PRGNAM-$VERSION ]; then
+ mv $PKG/usr/share/doc/$PRGNAM-$VERSION/html $PKG/usr/doc/$PRGNAM-$VERSION
+fi
+rm -rf $PKG/usr/share
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc