summaryrefslogtreecommitdiffstats
path: root/libraries/libportal/libportal.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/libportal/libportal.SlackBuild')
-rw-r--r--libraries/libportal/libportal.SlackBuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/libraries/libportal/libportal.SlackBuild b/libraries/libportal/libportal.SlackBuild
index 7995bb6c9e..0310533eb3 100644
--- a/libraries/libportal/libportal.SlackBuild
+++ b/libraries/libportal/libportal.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for libportal
-# Copyright 2020 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# Copyright 2020-2023 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=libportal
-VERSION=${VERSION:-0.3}
+VERSION=${VERSION:-0.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -66,6 +66,8 @@ fi
DOCS="COPYING NEWS README.md"
+if pkg-config --exists gi-docgen ; then DOX="true"; else DOX="false"; fi
+
set -e
rm -rf $PKG
@@ -81,6 +83,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/0.6-backports.patch
+sed -i "s|get_option('datadir') / 'doc'|get_option('prefix') / 'doc'|" doc/meson.build
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
@@ -92,7 +97,8 @@ cd build
--localstatedir=/var \
--mandir=/usr/man \
--prefix=/usr \
- --sysconfdir=/etc
+ --sysconfdir=/etc \
+ -Ddocs=$DOX
"${NINJA:=ninja}"
DESTDIR=$PKG $NINJA install
cd ..