summaryrefslogtreecommitdiffstats
path: root/libraries/matplotlib/matplotlib.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/matplotlib/matplotlib.SlackBuild')
-rw-r--r--libraries/matplotlib/matplotlib.SlackBuild110
1 files changed, 0 insertions, 110 deletions
diff --git a/libraries/matplotlib/matplotlib.SlackBuild b/libraries/matplotlib/matplotlib.SlackBuild
deleted file mode 100644
index b36e087fe0..0000000000
--- a/libraries/matplotlib/matplotlib.SlackBuild
+++ /dev/null
@@ -1,110 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for matplotlib
-
-# Copyright 2011-2019 Serban Udrea <s.udrea@gsi.de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification,
-# is permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
-# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
-# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
-
-# Written by Aleksandar Samardzic <asamardzic@gmail.com>
-# Updated to 0.99.1.2 by João Felipe Santos <joao.eel@gmail.com>
-# Patch for libpng borrowed from Arch Linux (no longer needed, 2016.08.28, S.U.)
-# Updated up to version 2.2.3 by Serban Udrea <S.Udrea@gsi.de>
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=matplotlib
-VERSION=${VERSION:-2.2.3}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-TARBALL_VERSION=${TARBALL_VERSION:-2.2.3} # Tarball may have wrong versioning
-ENABLE_TESTS=${ENABLE_TESTS:-N}
-DISABLE_WXAGG=${DISABLE_WXAGG:-Y}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$TARBALL_VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$TARBALL_VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-ENABLE_TESTS=$(echo "$ENABLE_TESTS"|cut -b 1|tr a-z A-Z)
-DISABLE_WXAGG=$(echo "$DISABLE_WXAGG"|cut -b 1|tr a-z A-Z)
-cat setup.cfg.template > setup.cfg
-
-if [ "$ENABLE_TESTS" = "Y" ]
-then
- sed -i "s|#tests = False|tests = True|" setup.cfg
-fi
-
-if [ "$DISABLE_WXAGG" = "Y" ]
-then
- sed -i "s|#wxagg = auto|wxagg = False|" setup.cfg
-fi
-
-# Use modified setupext.py to make sure that the build process gets
-# interrupted if requirements are not fulfilled
-#
-cat "${CWD}/setupext.py" > setupext.py
-
-python setup.py install --root $PKG # > ${CWD}/SETUP.OUTPUT 2>&1
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a INSTALL.rst MANIFEST.in README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE