summaryrefslogtreecommitdiffstats
path: root/libraries/ptypes/ptypes.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'libraries/ptypes/ptypes.SlackBuild')
-rw-r--r--libraries/ptypes/ptypes.SlackBuild34
1 files changed, 25 insertions, 9 deletions
diff --git a/libraries/ptypes/ptypes.SlackBuild b/libraries/ptypes/ptypes.SlackBuild
index 75617a7d2b..d0ae683bca 100644
--- a/libraries/ptypes/ptypes.SlackBuild
+++ b/libraries/ptypes/ptypes.SlackBuild
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for ptypes
@@ -22,10 +22,16 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - put HTML docs in correct Slackware doc dir.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=ptypes
VERSION=${VERSION:-2.1.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -35,7 +41,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -65,9 +75,9 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Fix up a to-be-installed header and the pkgconfig file
sed -i "s|/usr|${PKG}/usr|" src/Makefile.Linux
@@ -79,19 +89,25 @@ patch -p0 < $CWD/ptypes.patch
make all
make install
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20220419 bkw: nothing needs these static libs
+rm -f $PKG/usr/lib*/lib*.a
+
+# 20220419 bkw: shared libs are supposed to be executable.
+strip $PKG/usr/lib*/lib*.so.*
+chmod 755 $PKG/usr/lib*/lib*.so.*
# Install the pkgconfig file
mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
cat $CWD/ptypes.pc > $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/ptypes.pc
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/{extras,html}
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM/doc $PKG/usr/doc/$PRGNAM-$VERSION/html || true
+rm -rf $PKG/usr/share
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE