summaryrefslogtreecommitdiffstats
path: root/multimedia/mozplugger/mozplugger.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/mozplugger/mozplugger.SlackBuild')
-rw-r--r--multimedia/mozplugger/mozplugger.SlackBuild46
1 files changed, 25 insertions, 21 deletions
diff --git a/multimedia/mozplugger/mozplugger.SlackBuild b/multimedia/mozplugger/mozplugger.SlackBuild
index 8019ef4f91..c1a4caa94e 100644
--- a/multimedia/mozplugger/mozplugger.SlackBuild
+++ b/multimedia/mozplugger/mozplugger.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mozplugger
-# Copyright (c) jue oct 15 18:27:01 CST 2009, Dhaby Xiloj <slack.dhabyx@gmail.com>
+# Copyright (c) jue 2009, Dhaby Xiloj <slack.dhabyx@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -22,16 +22,14 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mozplugger
-VERSION=${VERSION:-1.13.0}
+VERSION=${VERSION:-1.14.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -41,8 +39,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="COPYING ChangeLog README"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -50,7 +46,7 @@ elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
+ SLKCFLAGS="-O2 -march=native -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
@@ -72,25 +68,34 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-RPM_OPT_FLAGS="$SLKCFLAGS" \
-make linux libprefix=/lib${LIBDIRSUFFIX}
-make install libprefix=/lib${LIBDIRSUFFIX} root=$PKG
+# sigh --rworkman
+patch -p1 < $CWD/Makefile.in.diff
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
+
+make \
+ XCFLAGS="$SLKCFLAGS" \
+ PLUGINDIRS=/usr/lib${LIBDIRSUFFIX}/mozilla/plugins \
+ libprefix=/lib64
+
+make install \
+ PLUGINDIRS=/usr/lib${LIBDIRSUFFIX}/mozilla/plugins \
+ libprefix=/lib64 \
+ root=$PKG
-# relocating files
-mv $PKG/usr/share/man $PKG/usr/man
-rm -Rf $PKG/usr/share
mv $PKG/etc/mozpluggerrc $PKG/etc/mozpluggerrc.new
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ar $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
@@ -99,4 +104,3 @@ cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-