summaryrefslogtreecommitdiffstats
path: root/network/ntop/no_downloads.patch
diff options
context:
space:
mode:
Diffstat (limited to 'network/ntop/no_downloads.patch')
-rw-r--r--network/ntop/no_downloads.patch142
1 files changed, 46 insertions, 96 deletions
diff --git a/network/ntop/no_downloads.patch b/network/ntop/no_downloads.patch
index d54d9a48a1..9574662b43 100644
--- a/network/ntop/no_downloads.patch
+++ b/network/ntop/no_downloads.patch
@@ -1,98 +1,48 @@
---- ntop-3.3.10.orig/configure.in 2009-11-27 23:36:09.000000000 -0200
-+++ ntop-3.3.10/configure.in 2009-11-28 10:16:33.000000000 -0200
-@@ -1652,21 +1652,12 @@
- dnl>
- dnl> Lua - http://www.lua.org
- dnl>
--LUA_VERSION=lua-5.1.4
--if test -f "$LUA_VERSION.tar.gz"; then
-- echo "Lua already present on this machine"
--else
-- wget http://www.lua.org/ftp/$LUA_VERSION.tar.gz
-+LUA_TEST=$(which lua > /dev/null 2> /dev/null ; echo $?)
-+if test $LUA_TEST -ne 0 ; then
-+ echo "*** Lua not installed ***"
-+ exit 1
- fi
--
--tar xvfz $LUA_VERSION.tar.gz
--cat $LUA_VERSION/src/Makefile | sed -e s,'MYCFLAGS=-DLUA_USE_POSIX',' MYCFLAGS="-fPIC -DLUA_USE_POSIX"',g > /tmp/lua.temp
--cat /tmp/lua.temp > $LUA_VERSION/src/Makefile
--#rm -f /tmp/lua.temp
--cd $LUA_VERSION; make posix; cd ..
--
--LUA_LIB_DIR=$PWD/$LUA_VERSION"/src"
--LIBS="-L${LUA_LIB_DIR} -llua ${LIBS} "
-+LIBS="-llua ${LIBS} "
- INCS="${INCS} -I${LUA_LIB_DIR}"
- AC_DEFINE_UNQUOTED(HAVE_LUA, 1, [LUA is supported])
-
-@@ -1963,39 +1954,13 @@
- fi
-
- dnl> GeoIP (http://www.maxmind.com/)
--if test -f "GeoIP.tar.gz"; then
-- echo "GeoIP already present on this machine"
--else
-- wget http://www.maxmind.com/download/geoip/api/c/GeoIP.tar.gz
--fi
--tar xvfz GeoIP.tar.gz
--GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
--cd $GEO_DIR; ./configure --prefix=${prefix}; make; cd ..
--# OSX Fix
--GEO_DYLIB="$GEO_DIR/libGeoIP/.libs/libGeoIP.dylib"
--if test -f $GEO_DYLIB; then
-- ln -s $GEO_DYLIB .
--fi
--
--if test -f "GeoLiteCity.dat"; then
-- echo "GeoLiteCity.dat already present"
--else
-- wget http://www.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
-- gunzip GeoLiteCity.dat.gz
--fi
--
--if test -f "GeoIPASNum.dat"; then
-- echo "GeoIPASNum.dat already present"
--else
-- wget http://www.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
-- gunzip GeoIPASNum.dat.gz
-+GEOIP_TEST=$(ldconfig -p | grep libGeoIP.so > /dev/null 2> /dev/null ; echo $?)
-+if test $GEOIP_TEST -ne 0 ; then
-+ echo "*** GeoIP not installed ***"
-+ exit 1
- fi
-
--
--GEO_DIR=`find $PWD -type d -name "GeoIP-*"`
--GEO_IP="$GEO_DIR/libGeoIP/"
--CFLAGS="$CFLAGS -I$GEO_IP"
--LDFLAGS="-L$GEO_IP.libs/ -lGeoIP $LDFLAGS"
-+LDFLAGS="-lGeoIP $LDFLAGS"
-
- dnl> NTOPCONFIGDEBUG_SETTINGS([precet])
-
---- ntop-3.3.10.orig/Makefile.am 2009-11-28 12:08:37.000000000 -0200
-+++ ntop-3.3.10/Makefile.am 2009-11-28 14:20:56.000000000 -0200
-@@ -74,11 +74,8 @@
- ETTER_PASSIVE_DOWNLOAD_PARMS = "rev=HEAD"
-
- NTOPDATA = ntop-cert.pem \
-- $(ETTER_PASSIVE) \
- oui.txt.gz \
-- specialMAC.txt.gz \
-- GeoIPASNum.dat \
-- GeoLiteCity.dat
-+ specialMAC.txt.gz
-
- NTOPHTML = html html/*.js html/*.html html/*.gif html/*.jpg html/*.ico html/*.png \
- html/*.css html/*.dtd \
-@@ -270,8 +267,6 @@
-
- install: install-recursive
+--- ntop-4.0.1_orig/Makefile.am 2010-04-25 09:52:28.000000000 -0300
++++ ntop-4.0.1/Makefile.am 2010-08-23 18:00:49.000000000 -0300
+@@ -403,44 +403,9 @@
+ dnetter:
+ @echo ""
+ @echo ""
+- @echo "Preparing "
++ @echo "Skipping download "
+ @echo ""
-- cd @GEO_DIR@; make install
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo "...Deleting prior file, $(ETTER_PASSIVE).old..."; \
+- rm -rf $(ETTER_PASSIVE).old; \
+- fi;
+- @if test -f $(ETTER_PASSIVE); then \
+- echo "...Moving current $(ETTER_PASSIVE) to $(ETTER_PASSIVE).old"; \
+- mv $(ETTER_PASSIVE) $(ETTER_PASSIVE).old; \
+- fi;
+- @for file in $(ETTER_PASSIVE) $(ETTER_PASSIVE).gz \
+- $(ETTER_PASSIVE_FILE) $(ETTER_PASSIVE_FILE).gz; do \
+- if test -f $$file; then \
+- echo "...Deleting prior file, $$file..."; \
+- rm -rf $$file; \
+- fi; \
+- done
+- @echo ""
+- @echo "...Downloading new file..."
+- @wget -O $(ETTER_PASSIVE_FILE) \
+- $(ETTER_PASSIVE_DOWNLOAD_FROM)/$(ETTER_PASSIVE_FILE)?$(ETTER_PASSIVE_DOWNLOAD_PARMS)
+- @echo ""
+- @echo "gziping downloaded file..."
+- @gzip $(ETTER_PASSIVE_FILE)
+- @echo ""
+- @echo ""
+- @if test -f $(ETTER_PASSIVE).old; then \
+- echo -n "Old file lines were: "; \
+- gunzip -c $(ETTER_PASSIVE).old | wc -l; \
+- fi;
+- @echo -n "New file lines are: "
+- @gunzip -c $(ETTER_PASSIVE) | wc -l
+- @echo ""
+- @echo ""
+- @echo "New file is:"
+- @ls -l $(ETTER_PASSIVE)
-
- @mkdir -p $(DESTDIR)/$(CFG_DBFILE_DIR)
-
- @echo ""
+ # ntop census
+ census-fail:
+ @echo "This option is no longer available... thanks for trying"