summaryrefslogtreecommitdiffstats
path: root/network/sic/sic.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/sic/sic.SlackBuild')
-rw-r--r--network/sic/sic.SlackBuild63
1 files changed, 50 insertions, 13 deletions
diff --git a/network/sic/sic.SlackBuild b/network/sic/sic.SlackBuild
index 6e05bc4249..cc4b1bf885 100644
--- a/network/sic/sic.SlackBuild
+++ b/network/sic/sic.SlackBuild
@@ -2,7 +2,7 @@
#
# Slackware build script for sic
# Copyright 2011 Haroldo F. Jardim <email removed>
-# Now maintained by B. Watson <yalhcru@gmail.com>
+# Now maintained by B. Watson <urchlay@slackware.uk>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,6 +22,15 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230103 bkw: update for v1.3, strip binary.
+
+# 20210924 bkw:
+# - update for latest git.
+# - add support for SLASH=yes.
+# - add support for user config.h.
+# - add support for patches.
+# - update README to reflect the above.
+
# 20201113 bkw: The original author of this script hasn't been heard
# from since 2011, and it needs some attention (still mentions i486)
# so I'm taking it.
@@ -35,7 +44,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sic
-VERSION=${VERSION:-1.2}
+VERSION=${VERSION:-1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -48,9 +57,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,30 +86,61 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.[xg]z
cd $PRGNAM-$VERSION
chown -R root:root .
chmod 644 *
-sed -i "s/CFLAGS =/CFLAGS +=/" config.mk
+# this is more complex than it has to be: upstream released a a mix
+# of -p0 and -p1 patches.
+for i in $CWD/patches/*.diff; do
+ if [ -e "$i" ]; then
+ P=1
+ patch --dry-run -p0 < $i &>/dev/null && P=0
+ echo "=== Applying $( basename $i ) with -p$P"
+ patch -p$P < $i
+ fi
+done
+
+if [ -e "$CWD/config.h" ]; then
+ # if the user's got his own config.h, use it
+ cat "$CWD/config.h" > config.h
+else
+ # if not, use the upstream default
+ cat config.def.h > config.h
+fi
+
+# IRCHOST IRCPORT SLASH modify the config.h, even overriding what's
+# in the user's custom one. Also fixup the man page.
+if [ -n "$IRCHOST" ]; then
+ sed -i "/DEFAULT_HOST/s,\".*\"\$,\"$IRCHOST\"," config.h
+ sed -i "/default host/s,(.*) *$,($IRCHOST)," $PRGNAM.1
+fi
-[ -n "$IRCHOST" ] && \
- sed -i "/host *= *\"/s,\"[^\"]*\",\"$IRCHOST\"," $PRGNAM.c
+if [ -n "$IRCPORT" ]; then
+ sed -i "/DEFAULT_PORT/s,\".*\"\$,\"$IRCPORT\"," config.h
+ sed -i "/default port/s,(.*) *$,($IRCPORT)," $PRGNAM.1
+fi
-[ -n "$IRCPORT" ] && \
- sed -i "/port *= *\"/s,\"[^\"]*\",\"$IRCPORT\"," $PRGNAM.c
+if [ "${SLASH:-no}" = "yes" ]; then
+ sed -i "s|':'|'/'|" config.h
+ sed -i '/^\.BI :/s,:,/,' $PRGNAM.1
+fi
-CFLAGS="$SLKCFLAGS -Wl,-s" \
+CFLAGS="$SLKCFLAGS" \
DESTDIR=$PKG \
make \
+ VERSION="$VERSION" \
+ CFLAGS="$SLKCFLAGS" \
PREFIX=/usr \
MANPREFIX=/usr/man \
install
+strip $PKG/usr/bin/$PRGNAM
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README config.h $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install