summaryrefslogtreecommitdiffstats
path: root/network/twine/twine.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/twine/twine.SlackBuild')
-rw-r--r--network/twine/twine.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/network/twine/twine.SlackBuild b/network/twine/twine.SlackBuild
index aecaa10aa3..77ff78a50d 100644
--- a/network/twine/twine.SlackBuild
+++ b/network/twine/twine.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for twine
-# Copyright 2016-2022 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=twine
-VERSION=${VERSION:-4.0.1}
+VERSION=${VERSION:-5.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -71,7 +71,6 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cp $CWD/setup.py $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -80,7 +79,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true