summaryrefslogtreecommitdiffstats
path: root/network/yturl/yturl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'network/yturl/yturl.SlackBuild')
-rw-r--r--network/yturl/yturl.SlackBuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/network/yturl/yturl.SlackBuild b/network/yturl/yturl.SlackBuild
deleted file mode 100644
index 5726f03045..0000000000
--- a/network/yturl/yturl.SlackBuild
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for yturl
-
-# Written by B. Watson (yalhcru@gmail.com)
-
-# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
-
-# 20180215 bkw: upgrade to 2.0.2.
-
-# 20170302 bkw: use long-format github URL
-
-# 20160727 bkw: upgrade to 2.0.1.
-
-# 20150910 bkw: upgrade to 1.20.0.
-# ARCH=noarch, there's no object code in the package.
-# Add DESCRIPTION section to man page.
-
-# 20150120 bkw: upgrade to 1.17.0. The old download URL was broken,
-# wonder how long for?
-# Use "python setup.py" since upstream has started requiring it.
-# Get rid of unused SLKCFLAGS and LIBDIRSUFFIX variables.
-
-# 20140316 bkw:
-# Updated to 1.16 release, use tar.gz instead of zip file. From now on
-# I'll track the releases instead of just grabbing current git... unless
-# youtube API changes break the release and upstream takes a long time to
-# make a new release.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=yturl
-VERSION=${VERSION:-2.0.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-ARCH=noarch
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/man/man1
-gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* LICENSE* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE