summaryrefslogtreecommitdiffstats
path: root/office/basket
diff options
context:
space:
mode:
Diffstat (limited to 'office/basket')
-rw-r--r--office/basket/README5
-rw-r--r--office/basket/basket.SlackBuild42
-rw-r--r--office/basket/basket.info2
-rw-r--r--office/basket/no-write-outside-destdir.patch19
4 files changed, 55 insertions, 13 deletions
diff --git a/office/basket/README b/office/basket/README
index bab4507c1e..2c4c7dae7e 100644
--- a/office/basket/README
+++ b/office/basket/README
@@ -1,2 +1,3 @@
-BasKet Note Pads is a note-taking application for KDE that makes it easy to
-write down ideas as you think, and quickly find them back later.
+BasKet Note Pads is a note-taking application for KDE that makes it
+easy to write down ideas as you think, and quickly find them back
+later.
diff --git a/office/basket/basket.SlackBuild b/office/basket/basket.SlackBuild
index b16c969bce..59b6593316 100644
--- a/office/basket/basket.SlackBuild
+++ b/office/basket/basket.SlackBuild
@@ -22,11 +22,19 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220407 bkw: Modified by SlackBuilds.org, BUILD=3:
+# - fix icon (wrong pixel size).
+
+# 20220404 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - no +x permission on .desktop file.
+# - no useless INSTALL in doc dir.
+# - install KDE HTML docs to /usr/doc/HTML (not /usr/share/doc/HTML).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=basket
VERSION=${VERSION:-2.49b}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +46,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +80,11 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+patch -p1 < $CWD/no-write-outside-destdir.patch
mkdir build
cd build
@@ -88,18 +95,33 @@ cd build
-DLIB_SUFFIX=${LIBDIRSUFFIX} \
-DCMAKE_BUILD_TYPE=Release ..
make
- make install DESTDIR=$PKG
+ make install/strip DESTDIR=$PKG
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+#find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ #| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/applications
+cp src/basket.desktop $PKG/usr/share/applications
+
+mkdir -p $PKG/usr/share/mime/packages/
+cp file-integration/basket.xml $PKG/usr/share/mime/packages/
+
+# 20220407 bkw: 128x128 icon is actually 126x126, fix.
+I=$PKG/usr/share/icons/hicolor/128x128/apps/basket.png
+convert -extent 128x128 -gravity center -background none $I new.png
+mv new.png $I
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- AUTHORS COPYING INSTALL README.md \
+ AUTHORS COPYING README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# 20220404 bkw: /usr/share/doc is verboten (it's a symlink to /usr/doc anyway).
+mv $PKG/usr/share/doc/HTML $PKG/usr/doc/HTML
+rm -rf $PKG/usr/share/doc
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
diff --git a/office/basket/basket.info b/office/basket/basket.info
index 57e51090c2..5014e52372 100644
--- a/office/basket/basket.info
+++ b/office/basket/basket.info
@@ -1,6 +1,6 @@
PRGNAM="basket"
VERSION="2.49b"
-HOMEPAGE="https://basket-notepads.github.io/"
+HOMEPAGE="https://github.com/basket-notepads/basket"
DOWNLOAD="https://github.com/basket-notepads/basket/archive/v2.49b/basket-2.49b.tar.gz"
MD5SUM="eabd8bf25b102d35f242d3494bea7b3d"
DOWNLOAD_x86_64=""
diff --git a/office/basket/no-write-outside-destdir.patch b/office/basket/no-write-outside-destdir.patch
new file mode 100644
index 0000000000..31795b1a7f
--- /dev/null
+++ b/office/basket/no-write-outside-destdir.patch
@@ -0,0 +1,19 @@
+diff -Nur basket-2.49b.orig/file-integration/CMakeLists.txt basket-2.49b/file-integration/CMakeLists.txt
+--- basket-2.49b.orig/file-integration/CMakeLists.txt 2019-02-27 14:33:04.000000000 -0600
++++ basket-2.49b/file-integration/CMakeLists.txt 2022-02-21 02:59:10.390850529 -0600
+@@ -11,15 +11,4 @@
+
+ ########### install files ###############
+
+-find_program(XDG-MIME_EXECUTABLE xdg-mime)
+-find_program(XDG-DESKTOP-MENU_EXECUTABLE xdg-desktop-menu)
+-
+ install(FILES basketthumbcreator.desktop DESTINATION ${SERVICES_INSTALL_DIR})
+-install(CODE "
+-execute_process(COMMAND ${XDG-MIME_EXECUTABLE} install --novendor
+- ${CMAKE_CURRENT_SOURCE_DIR}/basket.xml)
+-execute_process(COMMAND ${XDG-DESKTOP-MENU_EXECUTABLE} install
+- --novendor ${CMAKE_SOURCE_DIR}/src/basket.desktop)
+-execute_process(COMMAND ${XDG-MIME_EXECUTABLE} default
+- ${CMAKE_SOURCE_DIR}/src/basket.desktop application/x-basket-item)
+-")