summaryrefslogtreecommitdiffstats
path: root/perl/perl-WWW-Curl
diff options
context:
space:
mode:
Diffstat (limited to 'perl/perl-WWW-Curl')
-rw-r--r--perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch40
-rw-r--r--perl/perl-WWW-Curl/curl-7.71.0.patch.gzbin0 -> 527 bytes
-rw-r--r--perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild23
-rw-r--r--perl/perl-WWW-Curl/perl-WWW-Curl.info2
4 files changed, 18 insertions, 47 deletions
diff --git a/perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch b/perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch
deleted file mode 100644
index 2fecfce621..0000000000
--- a/perl/perl-WWW-Curl/WWW-Curl-4.150.0-curl-7.50.2.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-curl-7.50.2 introduced a #define without integer value:
-
- #ifdef CURL_NO_OLDIES
- #define CURL_STRICTER
- #endif
-
-Heuristics in 'Makefile.PL' assumes all defines in form of
- #define CURL_<something> <an-expression>
-and generates a symbol lookup table in 'curlopt-constants.c'
-as:
-
- static int
- constant(const char *name)
- {
- errno = 0;
-
- if (strncmp(name, "CURL_", 5) == 0) {
- name += 5;
- switch (*name) {
- ...
- case 'S':
- if (strEQ(name, "STRICTER")) return CURL_STRICTER;
-Which is not valid C:
- curlopt-constants.c:128:49: error: ‘CURL_STRICTER’ undeclared (first use in this function)
- if (strEQ(name, "STRICTER")) return CURL_STRICTER;
- ^~~~~~~~~~~~~
-diff --git a/Makefile.PL b/Makefile.PL
-index f9170bb..fc1a55a 100644
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -122,2 +122,9 @@ if (!defined($curl_h)) {
- while(<H>) {
-+ # Skip defines without values like:
-+ # #define CURL_STRICTER
-+ if (/^#define (CURL[A-Za-z0-9_]*)$/) {
-+ chomp;
-+ warn "Skipping '$_': does not define a symbol";
-+ next;
-+ }
- if (/^#define (CURL[A-Za-z0-9_]*)/) {
diff --git a/perl/perl-WWW-Curl/curl-7.71.0.patch.gz b/perl/perl-WWW-Curl/curl-7.71.0.patch.gz
new file mode 100644
index 0000000000..96e83e4a30
--- /dev/null
+++ b/perl/perl-WWW-Curl/curl-7.71.0.patch.gz
Binary files differ
diff --git a/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild b/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild
index c74feb165b..f99a85f115 100644
--- a/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild
+++ b/perl/perl-WWW-Curl/perl-WWW-Curl.SlackBuild
@@ -1,12 +1,15 @@
-#!/bin/sh
+#!/bin/bash
# Slackware build script for perl-WWW-Curl
# Written by Pragmatic Cypher <slackbuilds@server.ky>
+cd $(dirname $0) ; CWD=$(pwd)
+
PRGNAM=perl-WWW-Curl
VERSION=${VERSION:-4.17}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
SRCNAM=$(echo $PRGNAM | cut -f2- -d-)
@@ -18,7 +21,11 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -52,8 +59,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p1 < $CWD/WWW-Curl-4.150.0-curl-7.50.2.patch
+zcat $CWD/curl-7.71.0.patch.gz | patch -p1
+PERL_USE_UNSAFE_INC=1 \
+PERL_MM_USE_DEFAULT=1 \
perl Makefile.PL \
PREFIX=/usr \
INSTALLDIRS=vendor \
@@ -61,7 +70,9 @@ perl Makefile.PL \
INSTALLVENDORMAN3DIR=/usr/man/man3
make
-make test
+# 20220301 bkw: 'make test' requires internet access, don't run it
+# if it looks like the network is down (e.g. due to 'unshare -n').
+ping -w10 -c1 google.com &>/dev/null && make test
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
@@ -81,4 +92,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/perl/perl-WWW-Curl/perl-WWW-Curl.info b/perl/perl-WWW-Curl/perl-WWW-Curl.info
index f0c9a3599c..c2c9680284 100644
--- a/perl/perl-WWW-Curl/perl-WWW-Curl.info
+++ b/perl/perl-WWW-Curl/perl-WWW-Curl.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://cpan.metacpan.org/authors/id/S/SZ/SZBALINT/WWW-Curl-4.17.tar.g
MD5SUM="997ac81cd6b03b30b36f7cd930474845"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="perl-Module-Install"
MAINTAINER="Pragmatic Cypher"
EMAIL="slackbuilds@server.ky"