summaryrefslogtreecommitdiffstats
path: root/python/asttokens
diff options
context:
space:
mode:
Diffstat (limited to 'python/asttokens')
-rw-r--r--python/asttokens/README12
-rw-r--r--python/asttokens/asttokens.SlackBuild101
-rw-r--r--python/asttokens/asttokens.info10
-rw-r--r--python/asttokens/slack-desc19
4 files changed, 0 insertions, 142 deletions
diff --git a/python/asttokens/README b/python/asttokens/README
deleted file mode 100644
index 409a44dc4e..0000000000
--- a/python/asttokens/README
+++ /dev/null
@@ -1,12 +0,0 @@
-this module annotates Python abstact syntax trees (ASTs) with the
-positions of tokens and text in the source code that generated them
-
-It makes it possible for tools that work with logical AST nodes to find
-the particular text that resulted in those nodes, for example for
-automated refactoring or highlighting.
-
-It works with Python2 and Python3 and can annotate both trees built by
-ast, and those built by astroid.
-
-This (source) is downloaded from pypi.org/projects/asttokens as the
-github site may not have a complete sourcecode zip.
diff --git a/python/asttokens/asttokens.SlackBuild b/python/asttokens/asttokens.SlackBuild
deleted file mode 100644
index dddf974d79..0000000000
--- a/python/asttokens/asttokens.SlackBuild
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for asttokens
-
-# Written by Tim Dickson dickson.tim@googlemail.com
-# Copyright (c) 2019/2022 Tim Dickson, Scotland
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# note to self. github source tar.gz can miss out subdeps,
-# so use pypi.org/project/asttokens download source tar.gz instead.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=asttokens
-VERSION=${VERSION:-2.0.8}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-#lets do both python2 and python3
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/asttokens/asttokens.info b/python/asttokens/asttokens.info
deleted file mode 100644
index a30e9ef2b5..0000000000
--- a/python/asttokens/asttokens.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="asttokens"
-VERSION="2.0.8"
-HOMEPAGE="https://github.com/gristlabs/asttokens"
-DOWNLOAD="https://files.pythonhosted.org/packages/4d/c8/987ee029c83ad1cddb03bb004e9c7a8de1be4cdbda21122a0b9f639fcc31/asttokens-2.0.8.tar.gz"
-MD5SUM="ba3cb54e6a851636df293b8a4253f80f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-setuptools-scm wheel python-toml"
-MAINTAINER="Tim Dickson"
-EMAIL="dickson.tim@googlemail.com"
diff --git a/python/asttokens/slack-desc b/python/asttokens/slack-desc
deleted file mode 100644
index 5960537c96..0000000000
--- a/python/asttokens/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-asttokens: asttokens (an abstract syntax tree (AST) annotator for python)
-asttokens:
-asttokens: this module annotates Python abstact syntax trees (ASTs) with the
-asttokens: positions of tokens and text in the source code that generated them.
-asttokens:
-asttokens: It makes it possible for tools that work with logical AST nodes to
-asttokens: find the particular text that resulted in those nodes, for example
-asttokens: for automated refactoring or highlighting.
-asttokens:
-asttokens: Homepage http://github.com/gristlabs/asttokens
-asttokens: