summaryrefslogtreecommitdiffstats
path: root/python/foolscap/foolscap.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/foolscap/foolscap.SlackBuild')
-rw-r--r--python/foolscap/foolscap.SlackBuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/python/foolscap/foolscap.SlackBuild b/python/foolscap/foolscap.SlackBuild
index 179c746707..4e776ddd70 100644
--- a/python/foolscap/foolscap.SlackBuild
+++ b/python/foolscap/foolscap.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for foolscap.
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
-# Copyright 2012 Markus Reichelt, Aachen, DE
+# Copyright 2012-2014 Markus Reichelt, Stolberg (Rhld.), DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
PRGNAM=foolscap
-VERSION=${VERSION:-0.6.4}
+VERSION=${VERSION:-0.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,10 +68,10 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
@@ -79,9 +79,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- ChangeLog NEWS LICENSE README doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog* NEWS LICENSE README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install