summaryrefslogtreecommitdiffstats
path: root/python/gunicorn
diff options
context:
space:
mode:
Diffstat (limited to 'python/gunicorn')
-rw-r--r--python/gunicorn/gunicorn.SlackBuild13
-rw-r--r--python/gunicorn/gunicorn.info10
2 files changed, 11 insertions, 12 deletions
diff --git a/python/gunicorn/gunicorn.SlackBuild b/python/gunicorn/gunicorn.SlackBuild
index f11a48a386..46db2aef69 100644
--- a/python/gunicorn/gunicorn.SlackBuild
+++ b/python/gunicorn/gunicorn.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for gunicorn
-# Copyright 2016-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2016-2024 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gunicorn
-VERSION=${VERSION:-19.9.0}
+VERSION=${VERSION:-22.0.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,12 +79,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/gunicorn/gunicorn.info b/python/gunicorn/gunicorn.info
index a16cdb68a1..d8f62aee72 100644
--- a/python/gunicorn/gunicorn.info
+++ b/python/gunicorn/gunicorn.info
@@ -1,10 +1,10 @@
PRGNAM="gunicorn"
-VERSION="19.9.0"
+VERSION="22.0.0"
HOMEPAGE="https://gunicorn.org/"
-DOWNLOAD="https://files.pythonhosted.org/packages/47/52/68ba8e5e8ba251e54006a49441f7ccabca83b6bef5aedacb4890596c7911/gunicorn-19.9.0.tar.gz"
-MD5SUM="f581937e9d8569ebd3fd6af1f9ab809f"
+DOWNLOAD="https://files.pythonhosted.org/packages/1e/88/e2f93c5738a4c1f56a458fc7a5b1676fc31dcdbb182bef6b40a141c17d66/gunicorn-22.0.0.tar.gz"
+MD5SUM="c02e8493f941ebeddad35788f427aba2"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+EMAIL="dslackw@gmail.com"