summaryrefslogtreecommitdiffstats
path: root/python/huepy
diff options
context:
space:
mode:
Diffstat (limited to 'python/huepy')
-rw-r--r--python/huepy/huepy.SlackBuild18
-rw-r--r--python/huepy/huepy.info6
2 files changed, 6 insertions, 18 deletions
diff --git a/python/huepy/huepy.SlackBuild b/python/huepy/huepy.SlackBuild
index 8791a84733..f5e91712c3 100644
--- a/python/huepy/huepy.SlackBuild
+++ b/python/huepy/huepy.SlackBuild
@@ -6,6 +6,8 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230520 bkw: python => python2 (no other changes).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=huepy
@@ -31,20 +33,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -57,7 +45,7 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
rm -f $PKG/usr/LICENSE
diff --git a/python/huepy/huepy.info b/python/huepy/huepy.info
index a15c54ca3e..f0ecc575c4 100644
--- a/python/huepy/huepy.info
+++ b/python/huepy/huepy.info
@@ -1,10 +1,10 @@
PRGNAM="huepy"
VERSION="1.2.1"
HOMEPAGE="https://pypi.org/project/huepy/"
-DOWNLOAD="https://files.pythonhosted.org/packages/d6/4e/2dae447d8858a31158ca6c313f5d1902bc83b8542bb5f10c0307de2973bc/huepy-1.2.1.tar.gz"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/h/huepy/huepy-1.2.1.tar.gz"
MD5SUM="394a1072bec18c27097b053c40ddf0ea"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="urchlay@slackware.uk"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"