summaryrefslogtreecommitdiffstats
path: root/python/jaraco-packaging
diff options
context:
space:
mode:
Diffstat (limited to 'python/jaraco-packaging')
-rw-r--r--python/jaraco-packaging/jaraco-packaging.SlackBuild12
-rw-r--r--python/jaraco-packaging/jaraco-packaging.info2
2 files changed, 3 insertions, 11 deletions
diff --git a/python/jaraco-packaging/jaraco-packaging.SlackBuild b/python/jaraco-packaging/jaraco-packaging.SlackBuild
index 84e2b55bcd..4f003d6e9c 100644
--- a/python/jaraco-packaging/jaraco-packaging.SlackBuild
+++ b/python/jaraco-packaging/jaraco-packaging.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,12 +65,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/python/jaraco-packaging/jaraco-packaging.info b/python/jaraco-packaging/jaraco-packaging.info
index 1f20c7069c..4a85f4fa77 100644
--- a/python/jaraco-packaging/jaraco-packaging.info
+++ b/python/jaraco-packaging/jaraco-packaging.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://files.pythonhosted.org/packages/4f/4a/26b1b91079e189ec4e8bb151
MD5SUM="e255f3d73c0eb676826b8a35256852c5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python2-setuptools-scm python-toml"
+REQUIRES="python3-toml"
MAINTAINER="Prof. HORSTMANN"
EMAIL="wmh@eipg.fr"